Mediawiki Improper Privilege Management
CVE-2018-0503GHSA-mhfv-9h99-jwg7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/core 1.31.1, 1.30.1, 1.29.3, 1.27.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mediawiki/core
- Affected
- >= 1.27.0, < 1.27.5>= 1.29.0, < 1.29.3>= 1.30.0, < 1.30.1>= 1.31.0, < 1.31.1
- Fixed in
- 1.30.1, 1.31.1, 1.29.3, 1.27.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mhfv-9h99-jwg7 lists affected ranges: Packagist mediawiki/core >=1.27.0 =1.29.0 =1.30.0 =1.31.0 <1.31.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2018-0503: 1.56% estimated exploitation activity in the next 30 days; percentile 75.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where contrary to the documentation, $wgRateLimits entry for 'user' overrides that for 'newbie'.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mhfv-9h99-jwg7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-0503 Advisory: Mediawiki Improper Privilege Management IDs: CVE-2018-0503, GHSA-mhfv-9h99-jwg7 Record: https://patchnext.com/advisories/cve-2018-0503 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mediawiki/core 1.31.1, 1.30.1, 1.29.3, 1.27.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mediawiki/core: affected >= 1.27.0, < 1.27.5; >= 1.29.0, < 1.29.3; >= 1.30.0, < 1.30.1; >= 1.31.0, < 1.31.1; fixed in 1.30.1, 1.31.1, 1.29.3, 1.27.5 ## Suggested inspection (read-only) - Packagist mediawiki/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mediawiki/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mhfv-9h99-jwg7 (GitHub-reviewed advisory GHSA-mhfv-9h99-jwg7 lists affected ranges: Packagist mediawiki/core >=1.27.0 =1.29.0 =1.30.0 =1.31.0 <1.31.1) Commands are suggestions: review each one before running it.
Loading voting…