Skip to content

← Public intelligence

Packagist package

johnbillion/wp-crontrol

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.1PackagistPublished

    WP Crontrol Authenticated (Administrator+) plugin vulnerable to Blind Server-Side Request Forgery

    CVE-2025-8678 · GHSA-35c5-67fm-cpcp

    Affected
    • Packagist johnbillion/wp-crontrol >= 1.17.0, < 1.19.2
    Fixed in
    1.19.2· Vendor fix available
    Issue
    Impact The WP Crontrol plugin for WordPress is vulnerable to Blind Server-Side Request Forgery in versions 1.17.0 to 1.19.1 via the wpremoterequest() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. It is not possible for a user without Administrator level access to exploit this weakness. It is not possible for an Administrator performing an attack to see the HTTP response to the request to their chosen URL, nor is it possible for them to time the response. Patches WP Crontrol version 1.19.2 makes the following changes to harden the URL cron event feature: URLs are now validated for safety with the wphttpvalidateurl() function upon saving. The user is informed if they save a cron event containing a URL that is not considered safe, and the HTTP request will not trigger when the…

    Recommended action: Upgrade to 1.19.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.1PackagistPublished

    WP Crontrol vulnerable to possible RCE when combined with a pre-condition

    CVE-2024-28850 · GHSA-9xvf-cjvf-ff5q

    Affected
    • Packagist johnbillion/wp-crontrol < 1.16.2
    Fixed in
    1.16.2· Vendor fix available
    Issue
    Impact WP Crontrol includes a feature that allows administrative users to create events in the WP-Cron system that store and execute PHP code subject to the restrictive security permissions documented here. While there is no known vulnerability in this feature on its own, there exists potential for this feature to be vulnerable to RCE if it were specifically targeted via vulnerability chaining that exploited a separate SQLi (or similar) vulnerability. This is exploitable on a site if one of the below preconditions are met: The site is vulnerable to a writeable SQLi vulnerability in any plugin, theme, or WordPress core The site's database is compromised at the hosting level The site is vulnerable to a method of updating arbitrary options in the wpoptions table The site is vulnerable to a method of triggering an arbitrary action, filter, or function with control of the parameters Patches As a hardening measure, WP Crontrol version 1.16.2 ships with a new feature that prevents tampering…

    Recommended action: Upgrade to 1.16.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →