WP Crontrol Authenticated (Administrator+) plugin vulnerable to Blind Server-Side Request Forgery
CVE-2025-8678GHSA-35c5-67fm-cpcp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (johnbillion/wp-crontrol 1.19.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist johnbillion/wp-crontrol
- Affected
- >= 1.17.0, < 1.19.2
- Fixed in
- 1.19.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-35c5-67fm-cpcp lists affected ranges: Packagist johnbillion/wp-crontrol >=1.17.0 <1.19.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:L/VA:L/SC:N/SI:L/SA:L · score source
- EPSS
- CVE-2025-8678: 0.36% estimated exploitation activity in the next 30 days; percentile 30.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The WP Crontrol plugin for WordPress is vulnerable to Blind Server-Side Request Forgery in versions 1.17.0 to 1.19.1 via the wpremoterequest() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. It is not possible for a user without Administrator level access to exploit this weakness. It is not possible for an Administrator performing an attack to see the HTTP response to the request to their chosen URL, nor is it possible for them to time the response. Patches WP Crontrol version 1.19.2 makes the following changes to harden the URL cron event feature: URLs are now validated for safety with the wphttpvalidateurl() function upon saving. The user is informed if they save a cron event containing a URL that is not considered safe, and the HTTP request will not trigger when the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-35c5-67fm-cpcp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-8678 Advisory: WP Crontrol Authenticated (Administrator+) plugin vulnerable to Blind Server-Side Request Forgery IDs: CVE-2025-8678, GHSA-35c5-67fm-cpcp Record: https://patchnext.com/advisories/cve-2025-8678 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: johnbillion/wp-crontrol 1.19.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist johnbillion/wp-crontrol: affected >= 1.17.0, < 1.19.2; fixed in 1.19.2 ## Suggested inspection (read-only) - Packagist johnbillion/wp-crontrol: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on johnbillion/wp-crontrol. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-35c5-67fm-cpcp (GitHub-reviewed advisory GHSA-35c5-67fm-cpcp lists affected ranges: Packagist johnbillion/wp-crontrol >=1.17.0 <1.19.2) Commands are suggestions: review each one before running it.
Loading voting…