Skip to content

← Actionable
High, CVSS 8.1

WP Crontrol vulnerable to possible RCE when combined with a pre-condition

CVE-2024-28850GHSA-9xvf-cjvf-ff5q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (johnbillion/wp-crontrol 1.16.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-28850: 0.17% estimated exploitation activity in the next 30 days; percentile 5.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact WP Crontrol includes a feature that allows administrative users to create events in the WP-Cron system that store and execute PHP code subject to the restrictive security permissions documented here. While there is no known vulnerability in this feature on its own, there exists potential for this feature to be vulnerable to RCE if it were specifically targeted via vulnerability chaining that exploited a separate SQLi (or similar) vulnerability. This is exploitable on a site if one of the below preconditions are met: The site is vulnerable to a writeable SQLi vulnerability in any plugin, theme, or WordPress core The site's database is compromised at the hosting level The site is vulnerable to a method of updating arbitrary options in the wpoptions table The site is vulnerable to a method of triggering an arbitrary action, filter, or function with control of the parameters Patches As a hardening measure, WP Crontrol version 1.16.2 ships with a new feature that prevents tampering…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9xvf-cjvf-ff5q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28850

Advisory: WP Crontrol vulnerable to possible RCE when combined with a pre-condition
IDs: CVE-2024-28850, GHSA-9xvf-cjvf-ff5q
Record: https://patchnext.com/advisories/cve-2024-28850 (revision 1, source checked 26 Oct 2026, 14:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: johnbillion/wp-crontrol 1.16.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist johnbillion/wp-crontrol: affected < 1.16.2; fixed in 1.16.2

## Suggested inspection (read-only)
- Packagist johnbillion/wp-crontrol: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on johnbillion/wp-crontrol.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9xvf-cjvf-ff5q (GitHub-reviewed advisory GHSA-9xvf-cjvf-ff5q lists affected ranges: Packagist johnbillion/wp-crontrol >=0 <1.16.2)

Commands are suggestions: review each one before running it.

Loading voting…