Skip to content

← Public intelligence

Packagist package

illuminate/database

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPackagistPublished

    Laravel Risk of mass-assignment vulnerabilities

    GHSA-cc2w-ghc5-m5qr

    Affected
    • Packagist illuminate/database >= 4.0.0, < 4.1.29
    Fixed in
    4.1.29· Vendor fix available
    Issue
    Laravel 4.1.29 improves the column quoting for all database drivers. This protects your application from some mass assignment vulnerabilities when not using the fillable property on models. If you are using the fillable property on your models to protect against mass assignment, your application is not vulnerable. However, if you are using guarded and are passing a user controlled array into an "update" or "save" type function, you should upgrade to 4.1.29 immediately as your application may be at risk of mass assignment.

    Recommended action: Upgrade to 4.1.29 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5PackagistPublished

    Guard bypass in Eloquent models affecting Laravel illuminate database component

    CVE-2020-24940 · GHSA-c7rm-w2hj-x8g3

    Affected
    • Packagist illuminate/database >= 5.5.0, <= 5.5.44; >= 6.0.0, < 6.18.34; >= 7.0.0, < 7.23.2
    Fixed in
    6.18.347.23.2· Partial vendor fix
    Issue
    An issue was discovered in Laravel before 6.18.34 and 7.x before 7.23.2. Unvalidated values are saved to the database component in some situations in which table names are stripped during a mass assignment.

    Recommended action: Upgrade to 7.23.2 or 6.18.34 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedPackagistPublished

    SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database

    GHSA-4mg9-vhxq-vm7j

    Affected
    • Packagist illuminate/database >= 8.0.0, < 8.40.0; < 6.20.26
    Fixed in
    6.20.268.40.0· Vendor fix available
    Issue
    Impact Those using SQL Server with Laravel and allowing user input to be passed directly to the limit and offset functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability. Patches This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0. Workarounds You may workaround this vulnerability by ensuring that only integers are passed to the limit and offset functions, as well as the skip and take functions.

    Recommended action: Upgrade to 8.40.0 or 6.20.26 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.2PackagistPublished

    Unexpected database bindings

    GHSA-x7p5-p2c9-phvg

    Affected
    • Packagist illuminate/database < 6.20.14; >= 7.0.0, < 7.30.4; >= 8.0.0, < 8.24.0
    Fixed in
    8.24.07.30.46.20.14· Vendor fix available
    Issue
    This is a follow-up to the previous security advisory (GHSA-3p32-j457-pg5x) which addresses a few additional edge cases. If a request is crafted where a field that is normally a non-array value is an array, and that input is not validated or cast to its expected type before being passed to the query builder, an unexpected number of query bindings can be added to the query. In some situations, this will simply lead to no results being returned by the query builder; however, it is possible certain queries could be affected in a way that causes the query to return unexpected results.

    Recommended action: Upgrade to 8.24.0, 7.30.4 or 6.20.14 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 7.2PackagistPublished

    Query Binding Exploitation

    CVE-2021-21263 · GHSA-3p32-j457-pg5x

    Affected
    • Packagist illuminate/database >= 7.0.0, < 7.30.3; >= 8.0.0, < 8.22.1; >= 6.0.0, < 6.20.12
    Fixed in
    6.20.128.22.17.30.3· Vendor fix available
    Issue
    Laravel versions <6.20.12, <7.30.3 & <8.22.1 contain a query binding exploitation. If a request is crafted where a field that is normally a non-array value is an array, and that input is not validated or cast to its expected type before being passed to the query builder, an unexpected number of query bindings can be added to the query. In some situations, this will simply lead to no results being returned by the query builder; however, it is possible certain queries could be affected in a way that causes the query to return unexpected results. This vulnerability was discovered by Tim Groenevelt (tim.g@foodbyus.com). References - https://github.com/laravel/framework/pull/35865

    Recommended action: Upgrade to 8.22.1, 7.30.3 or 6.20.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →