Skip to content

← Actionable
High, CVSS 7.2

Unexpected database bindings

GHSA-x7p5-p2c9-phvg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/framework 8.24.0, 7.30.4, 6.20.14; illuminate/database 8.24.0, 7.30.4, 6.20.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist laravel/framework

    Affected
    < 6.20.14>= 7.0.0, < 7.30.4>= 8.0.0, < 8.24.0
    Fixed in
    8.24.0, 7.30.4, 6.20.14
  • Packagist illuminate/database

    Affected
    < 6.20.14>= 7.0.0, < 7.30.4>= 8.0.0, < 8.24.0
    Fixed in
    8.24.0, 7.30.4, 6.20.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

This is a follow-up to the previous security advisory (GHSA-3p32-j457-pg5x) which addresses a few additional edge cases. If a request is crafted where a field that is normally a non-array value is an array, and that input is not validated or cast to its expected type before being passed to the query builder, an unexpected number of query bindings can be added to the query. In some situations, this will simply lead to no results being returned by the query builder; however, it is possible certain queries could be affected in a way that causes the query to return unexpected results.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x7p5-p2c9-phvg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-x7p5-p2c9-phvg

Advisory: Unexpected database bindings
IDs: GHSA-x7p5-p2c9-phvg
Record: https://patchnext.com/advisories/ghsa-x7p5-p2c9-phvg (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: laravel/framework 8.24.0, 7.30.4, 6.20.14; illuminate/database 8.24.0, 7.30.4, 6.20.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist laravel/framework: affected < 6.20.14; >= 7.0.0, < 7.30.4; >= 8.0.0, < 8.24.0; fixed in 8.24.0, 7.30.4, 6.20.14
- Packagist illuminate/database: affected < 6.20.14; >= 7.0.0, < 7.30.4; >= 8.0.0, < 8.24.0; fixed in 8.24.0, 7.30.4, 6.20.14

## Suggested inspection (read-only)
- Packagist laravel/framework: check the installed version with your package manager.
- Packagist illuminate/database: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on laravel/framework, illuminate/database.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x7p5-p2c9-phvg (GitHub-reviewed advisory GHSA-x7p5-p2c9-phvg lists affected ranges: Packagist laravel/framework >=0 =7.0.0 =8.0.0 =0 =7.0.0 =8.0.0 <8.24.0)

Commands are suggestions: review each one before running it.

Loading voting…