Guard bypass in Eloquent models affecting Laravel illuminate database component
CVE-2020-24940GHSA-c7rm-w2hj-x8g3
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist illuminate/database
- Affected
- >= 5.5.0, <= 5.5.44>= 6.0.0, < 6.18.34>= 7.0.0, < 7.23.2
- Fixed in
- 6.18.34, 7.23.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c7rm-w2hj-x8g3 lists affected ranges: Packagist illuminate/database >=5.5.0 =6.0.0 =7.0.0 <7.23.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2020-24940: 1.20% estimated exploitation activity in the next 30 days; percentile 68.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Laravel before 6.18.34 and 7.x before 7.23.2. Unvalidated values are saved to the database component in some situations in which table names are stripped during a mass assignment.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c7rm-w2hj-x8g3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-24940 Advisory: Guard bypass in Eloquent models affecting Laravel illuminate database component IDs: CVE-2020-24940, GHSA-c7rm-w2hj-x8g3 Record: https://patchnext.com/advisories/cve-2020-24940 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: illuminate/database 7.23.2, 6.18.34. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist illuminate/database: affected >= 5.5.0, <= 5.5.44; >= 6.0.0, < 6.18.34; >= 7.0.0, < 7.23.2; fixed in 6.18.34, 7.23.2 ## Suggested inspection (read-only) - Packagist illuminate/database: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on illuminate/database. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c7rm-w2hj-x8g3 (GitHub-reviewed advisory GHSA-c7rm-w2hj-x8g3 lists affected ranges: Packagist illuminate/database >=5.5.0 =6.0.0 =7.0.0 <7.23.2) Commands are suggestions: review each one before running it.
Loading voting…