Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
110 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
Drupal's JSON:API and REST/File modules allow file uploads through their HTTP APIs. The modules do not correctly run all file validation, which causes an access bypass vulnerability. An attacker might be able to upload files that bypass the file validation process implemented by modules on the site.
Recommended action: Upgrade to 9.2.6, 9.1.13 or 8.9.19 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
The QuickEdit module does not properly validate access to routes, which could allow cross-site request forgery under some circumstances and lead to possible data integrity issues. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed. Removing the "access in-place editing" permission from untrusted users will not fully mitigate the vulnerability.
Recommended action: Upgrade to 9.2.6, 9.1.13 or 8.9.19 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Under some circumstances, the Drupal core JSON:API module does not properly restrict access to certain content, which may result in unintended access bypass. Sites that do not have the JSON:API module enabled are not affected.
Recommended action: Upgrade to 9.2.6, 9.1.13 or 8.9.19 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
The QuickEdit module does not properly check access to fields in some circumstances, which can lead to unintended disclosure of field data. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed.
Recommended action: Upgrade to 9.2.6, 9.1.13 or 8.9.19 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6, and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on an untrusted phar:// URI. Some Drupal code (core, contrib, and custom) may be performing file operations on insufficiently validated user input, thereby being exposed to this vulnerability. This vulnerability is mitigated by the fact that such code paths typically require access to an administrative permission or an atypical configuration.
Recommended action: Upgrade to 8.6.6, 8.5.9 or 7.62.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Drupal core does not properly sanitize certain filenames on uploaded files, which can lead to files being interpreted as the incorrect extension and served as the wrong MIME type or executed as PHP for certain hosting configurations. This issue affects: Drupal Drupal Core 9.0 versions prior to 9.0.8, 8.9 versions prior to 8.9.9, 8.8 versions prior to 8.8.11, and 7 versions prior to 7.74.
Recommended action: Upgrade to 9.0.8, 8.9.9, 8.8.11 or 7.74 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
The PharStreamWrapper (aka phar-stream-wrapper) package 2.x before 2.1.1 and 3.x before 3.1.1 for TYPO3 does not prevent directory traversal, which allows attackers to bypass a deserialization protection mechanism, as demonstrated by a phar:///path/bad.phar/../good.phar URL.
Recommended action: Upgrade to 8.7.1, 8.6.16 or 7.67.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --! is mishandled.
Recommended action: Upgrade to 9.1.9, 9.0.14, 8.9.16 or 7.80 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not escaped, which can lead to XSS when user input is included. This is related to symfony/framework-bundle.
Recommended action: Upgrade to 8.6.15 or 8.5.15 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In Drupal 8.x prior to 8.3.7 When creating a view, you can optionally use Ajax to update the displayed data via filter parameters. The views subsystem/module did not restrict access to the Ajax endpoint to only views configured to use Ajax. This is mitigated if you have access restrictions on the view. It is best practice to always include some form of access restrictions on all views, even if you are using another module to display them.
Recommended action: Upgrade to 8.3.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.