Skip to content

← Actionable
Medium, CVSS 6.1amended

ckeditor4 vulnerable to cross-site scripting

CVE-2021-33829GHSA-rgx6-rjj4-c388

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.1.9, 9.0.14, 8.9.16, 7.80; ckeditor4 4.16.1; drupal/drupal 9.1.9, 9.0.14, 8.9.16, 7.80), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 7.0.0, < 7.80>= 8.0.0, < 8.9.16>= 9.0.0, < 9.0.14>= 9.1.0, < 9.1.9
    Fixed in
    9.1.9, 7.80, 8.9.16, 9.0.14
  • npm ckeditor4

    Affected
    >= 4.14.0, < 4.16.1
    Fixed in
    4.16.1
  • Packagist drupal/drupal

    Affected
    >= 7.0.0, < 7.80>= 8.0.0, < 8.9.16>= 9.0.0, < 9.0.14>= 9.1.0, < 9.1.9
    Fixed in
    9.1.9, 7.80, 8.9.16, 9.0.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-33829: 3.19% estimated exploitation activity in the next 30 days; percentile 88.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --! is mishandled.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rgx6-rjj4-c388

  2. Revision 1 · created ·

    Published from osv record GHSA-rgx6-rjj4-c388

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-33829

Advisory: ckeditor4 vulnerable to cross-site scripting
IDs: CVE-2021-33829, GHSA-rgx6-rjj4-c388
Record: https://patchnext.com/advisories/cve-2021-33829 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.1.9, 9.0.14, 8.9.16, 7.80; ckeditor4 4.16.1; drupal/drupal 9.1.9, 9.0.14, 8.9.16, 7.80. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 7.0.0, < 7.80; >= 8.0.0, < 8.9.16; >= 9.0.0, < 9.0.14; >= 9.1.0, < 9.1.9; fixed in 9.1.9, 7.80, 8.9.16, 9.0.14
- npm ckeditor4: affected >= 4.14.0, < 4.16.1; fixed in 4.16.1
- Packagist drupal/drupal: affected >= 7.0.0, < 7.80; >= 8.0.0, < 8.9.16; >= 9.0.0, < 9.0.14; >= 9.1.0, < 9.1.9; fixed in 9.1.9, 7.80, 8.9.16, 9.0.14

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- `npm ls ckeditor4 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, ckeditor4, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rgx6-rjj4-c388 (OSV record GHSA-rgx6-rjj4-c388 lists affected ranges: npm ckeditor4 >=4.14.0 =7.0.0 =8.0.0 =9.0.0 =9.1.0 =7.0.0 =8.0.0 =9.0.0 =9.1.0 <9.1.9 (fixed))
- Verified: https://github.com/advisories/GHSA-rgx6-rjj4-c388 (GitHub-reviewed advisory GHSA-rgx6-rjj4-c388 lists affected ranges: npm ckeditor4 >=4.14.0 =7.0.0 =8.0.0 =9.0.0 =9.1.0 =7.0.0 =8.0.0 =9.0.0 =9.1.0 <9.1.9)

Commands are suggestions: review each one before running it.

Loading voting…