Skip to content

← Actionable
High, CVSS 8.8Exploited · CISA KEV

Drupal core Unrestricted Upload of File with Dangerous Type

CVE-2020-13671GHSA-68jc-v27h-vhmw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.0.8, 8.9.9, 8.8.11, 7.74; drupal/drupal 9.0.8, 8.9.9, 8.8.11, 7.74), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 9.0.0, < 9.0.8>= 8.9.0, < 8.9.9>= 8.0.0, < 8.8.11>= 7.0.0, < 7.74
    Fixed in
    7.74, 8.8.11, 8.9.9, 9.0.8
  • Packagist drupal/drupal

    Affected
    >= 7.0.0, < 7.74>= 8.0.0, < 8.8.11>= 8.9.0, < 8.9.9>= 9.0.0, < 9.0.8
    Fixed in
    7.74, 8.8.11, 8.9.9, 9.0.8

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-68jc-v27h-vhmw lists affected ranges: Packagist drupal/core >=9.0.0 =8.9.0 =8.0.0 =7.0.0 =7.0.0 =8.0.0 =8.9.0 =9.0.0 <9.0.8

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

  • CISA Known Exploited Vulnerabilities Catalog

    CISA added CVE-2020-13671 to the Known Exploited Vulnerabilities catalog on 2022-01-18.

    VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2022-01-18).

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2020-13671: 36.17% estimated exploitation activity in the next 30 days; percentile 98.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Drupal core does not properly sanitize certain filenames on uploaded files, which can lead to files being interpreted as the incorrect extension and served as the wrong MIME type or executed as PHP for certain hosting configurations. This issue affects: Drupal Drupal Core 9.0 versions prior to 9.0.8, 8.9 versions prior to 8.9.9, 8.8 versions prior to 8.8.11, and 7 versions prior to 7.74.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-68jc-v27h-vhmw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13671

Advisory: Drupal core Unrestricted Upload of File with Dangerous Type
IDs: CVE-2020-13671, GHSA-68jc-v27h-vhmw
Record: https://patchnext.com/advisories/cve-2020-13671 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.0.8, 8.9.9, 8.8.11, 7.74; drupal/drupal 9.0.8, 8.9.9, 8.8.11, 7.74. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 9.0.0, < 9.0.8; >= 8.9.0, < 8.9.9; >= 8.0.0, < 8.8.11; >= 7.0.0, < 7.74; fixed in 7.74, 8.8.11, 8.9.9, 9.0.8
- Packagist drupal/drupal: affected >= 7.0.0, < 7.74; >= 8.0.0, < 8.8.11; >= 8.9.0, < 8.9.9; >= 9.0.0, < 9.0.8; fixed in 7.74, 8.8.11, 8.9.9, 9.0.8

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-68jc-v27h-vhmw (GitHub-reviewed advisory GHSA-68jc-v27h-vhmw lists affected ranges: Packagist drupal/core >=9.0.0 =8.9.0 =8.0.0 =7.0.0 =7.0.0 =8.0.0 =8.9.0 =9.0.0 <9.0.8)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2020-13671 to the Known Exploited Vulnerabilities catalog on 2022-01-18.)

Commands are suggestions: review each one before running it.

Loading voting…