Skip to content

← Public intelligence

Packagist package

alextselegidis/easyappointments

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 3.3PackagistAmendedPublished

    Easy!Appointments appointments/store and appointments/update allow cross-provider appointment injection — Authorization Bypass

    CVE-2026-52839 · GHSA-w8xc-8g92-v77h

    Affected
    • Packagist alextselegidis/easyappointments <= 1.5.2
    Fixed in
    1.6.0· Vendor fix available
    Issue
    Easy!Appointments correctly filters provider-scoped appointments in the appointments/search response, proving that provider isolation is an intended security boundary. However, the direct mutation endpoints appointments/store and appointments/update only check generic appointment privileges and never verify that the submitted idusersprovider belongs to the current session. A normal authenticated provider can inject new appointments into another provider's schedule via store, or reassign existing appointments into a foreign provider's calendar via update. The store path contains an additional write-before-crash bug: the unauthorized row is committed to the database before the controller crashes on a type error, so the attacker receives an error response while the foreign appointment is already persisted. --- Root Cause — Step by Step Code Flow Step 1 — Search correctly enforces provider isolation The search endpoint filters out appointments belonging to other providers —…

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.7PackagistPublished

    Easy!Appointments SQL injection vulnerability

    CVE-2025-50383 · GHSA-2f28-69j7-85hf

    Affected
    • Packagist alextselegidis/easyappointments < 1.5.2-beta.1
    Fixed in
    1.5.2-beta.1· Vendor fix available
    Issue
    alextselegidis Easy!Appointments v1.5.1 was discovered to contain a SQL injection vulnerability via the orderby parameter.

    Recommended action: Upgrade to 1.5.2-beta.1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.3PackagistPublished

    Easy!Appointments Improper Access Control vulnerability

    CVE-2023-3700 · GHSA-8c6q-26w6-qwhg

    Affected
    • Packagist alextselegidis/easyappointments <= 1.4.3
    Fixed in
    1.5.0· Vendor fix available
    Issue
    Easy!Appointments 1.4.3 and prior has an Improper Access Control vulnerability. This issue is patched at commit b37b46019553089db4f22eb2fe998bca84b2cb64 and anticipated to be part of version 1.5.0.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.3PackagistPublished

    Code Injection in alextselegidis/easyappointments

    CVE-2023-1367 · GHSA-9qvw-fhj2-xqmv

    Affected
    • Packagist alextselegidis/easyappointments < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    Code Injection in GitHub repository alextselegidis/easyappointments prior to 1.5.0 due to unescaped output.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.1PackagistPublished

    Exposure of Private Personal Information to an Unauthorized Actor in alextselegidis/easyappointments

    CVE-2022-0482 · GHSA-r6cm-wg48-rh2r

    Affected
    • Packagist alextselegidis/easyappointments < 1.4.3
    Fixed in
    1.4.3· Vendor fix available
    Issue
    The software is a booking management system that has a public form to place bookings, and a private area for the calendar and management of services, users, settings, etc. There is a backend API that allows data manipulation, including listing the appointments for a specific time range. This happens on this endpoint: /index.php/backendapi/ajaxgetcalendarevents Unfortunately, there is no authentication / permissions-check on that endpoint, the only required parameters in a POST request are "startDate", "endDate" and "csrfToken". Because the csrfToken can be obtained by any unauthenticated user just visiting the public form (and is valid for the backend as well), any attacker can query the backend API and obtain all sorts of private information about the appointment, in JSON format.

    Recommended action: Upgrade to 1.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →