Skip to content

← Actionable
Low, CVSS 3.3amended

Easy!Appointments appointments/store and appointments/update allow cross-provider appointment injection — Authorization Bypass

CVE-2026-52839GHSA-w8xc-8g92-v77h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (alextselegidis/easyappointments 1.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-52839: 0.18% estimated exploitation activity in the next 30 days; percentile 7.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Easy!Appointments correctly filters provider-scoped appointments in the appointments/search response, proving that provider isolation is an intended security boundary. However, the direct mutation endpoints appointments/store and appointments/update only check generic appointment privileges and never verify that the submitted idusersprovider belongs to the current session. A normal authenticated provider can inject new appointments into another provider's schedule via store, or reassign existing appointments into a foreign provider's calendar via update. The store path contains an additional write-before-crash bug: the unauthorized row is committed to the database before the controller crashes on a type error, so the attacker receives an error response while the foreign appointment is already persisted. --- Root Cause — Step by Step Code Flow Step 1 — Search correctly enforces provider isolation The search endpoint filters out appointments belonging to other providers —…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w8xc-8g92-v77h

  2. Revision 1 · created ·

    Published from osv record GHSA-w8xc-8g92-v77h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52839

Advisory: Easy!Appointments appointments/store and appointments/update allow cross-provider appointment injection — Authorization Bypass
IDs: CVE-2026-52839, GHSA-w8xc-8g92-v77h
Record: https://patchnext.com/advisories/cve-2026-52839 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: alextselegidis/easyappointments 1.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist alextselegidis/easyappointments: affected <= 1.5.2; fixed in 1.6.0

## Suggested inspection (read-only)
- Packagist alextselegidis/easyappointments: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on alextselegidis/easyappointments.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w8xc-8g92-v77h (OSV record GHSA-w8xc-8g92-v77h lists affected ranges: Packagist alextselegidis/easyappointments >=0 <1.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w8xc-8g92-v77h (GitHub-reviewed advisory GHSA-w8xc-8g92-v77h lists affected ranges: Packagist alextselegidis/easyappointments >=0 <=1.5.2)

Commands are suggestions: review each one before running it.

Loading voting…