Exposure of Private Personal Information to an Unauthorized Actor in alextselegidis/easyappointments
CVE-2022-0482GHSA-r6cm-wg48-rh2r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (alextselegidis/easyappointments 1.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist alextselegidis/easyappointments
- Affected
- < 1.4.3
- Fixed in
- 1.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r6cm-wg48-rh2r lists affected ranges: Packagist alextselegidis/easyappointments >=0 <1.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2022-0482: 43.75% estimated exploitation activity in the next 30 days; percentile 98.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The software is a booking management system that has a public form to place bookings, and a private area for the calendar and management of services, users, settings, etc. There is a backend API that allows data manipulation, including listing the appointments for a specific time range. This happens on this endpoint: /index.php/backendapi/ajaxgetcalendarevents Unfortunately, there is no authentication / permissions-check on that endpoint, the only required parameters in a POST request are "startDate", "endDate" and "csrfToken". Because the csrfToken can be obtained by any unauthenticated user just visiting the public form (and is valid for the backend as well), any attacker can query the backend API and obtain all sorts of private information about the appointment, in JSON format.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r6cm-wg48-rh2r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-0482 Advisory: Exposure of Private Personal Information to an Unauthorized Actor in alextselegidis/easyappointments IDs: CVE-2022-0482, GHSA-r6cm-wg48-rh2r Record: https://patchnext.com/advisories/cve-2022-0482 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: alextselegidis/easyappointments 1.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist alextselegidis/easyappointments: affected < 1.4.3; fixed in 1.4.3 ## Suggested inspection (read-only) - Packagist alextselegidis/easyappointments: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on alextselegidis/easyappointments. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r6cm-wg48-rh2r (GitHub-reviewed advisory GHSA-r6cm-wg48-rh2r lists affected ranges: Packagist alextselegidis/easyappointments >=0 <1.4.3) Commands are suggestions: review each one before running it.
Loading voting…