Skip to content

← Public intelligence

Packagist package

aimeos/ai-admin-graphql

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.5PackagistPublished

    ai-admin-graphql has a Denial of service vulnerability in SaaS and marketplace setups

    CVE-2024-47173 · GHSA-qxgx-hvg3-v92w

    Affected
    • Packagist aimeos/ai-admin-graphql >= 2024.04.1, < 2024.07.2
    Fixed in
    2024.07.2· Vendor fix available
    Issue
    All SaaS and marketplace setups using Aimeos version from 2024.04 up to 2024.07.1 are affected by a potential denial of service attack

    Recommended action: Upgrade to 2024.07.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Low, CVSS 3.8PackagistPublished

    aimeos/ai-admin-graphql improper access control vulnerability allows editors to manage own services

    CVE-2024-39324 · GHSA-jj68-cp4v-98qf

    Affected
    • Packagist aimeos/ai-admin-graphql >= 2022.04.1, < 2022.10.10; >= 2023.04.1, < 2023.10.6; >= 2024.04.1, <= 2024.04.1
    Fixed in
    2022.10.102023.10.62024.04.2· Vendor fix available
    Issue
    aimeos/ai-admin-graphql is the Aimeos GraphQL API admin interface. Starting in version 2022.04.1 and prior to versions 2022.10.10, 2023.10.6, and 2024.4.2, improper access control allows a editors to manage own services via GraphQL API which isn't allowed in the JQAdm front end. Versions 2022.10.10, 2023.10.6, and 2024.4.2 contain a patch for the issue.

    Recommended action: Upgrade to 2024.04.2, 2023.10.6 or 2022.10.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.2PackagistPublished

    aimeos/ai-admin-graphql improper access control vulnerability allows an editor to modify admin account

    CVE-2024-39323 · GHSA-vc7j-99jw-jrqm

    Affected
    • Packagist aimeos/ai-admin-graphql >= 2022.04.1, < 2022.10.10; >= 2023.04.1, < 2023.10.6; >= 2024.04.1, < 2024.04.6
    Fixed in
    2024.04.62022.10.102023.10.6· Vendor fix available
    Issue
    aimeos/ai-admin-graphql is the Aimeos GraphQL API admin interface. Starting in version 2022.04.01 and prior to versions 2022.10.10, 2023.10.6, and 2024.04.6, an improper access control vulnerability allows an editor to modify and take over an admin account in the back end. Versions 2022.10.10, 2023.10.6, and 2024.04.6 fix this issue.

    Recommended action: Upgrade to 2024.04.6, 2023.10.6 or 2022.10.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →