aimeos/ai-admin-graphql improper access control vulnerability allows an editor to modify admin account
CVE-2024-39323GHSA-vc7j-99jw-jrqm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aimeos/ai-admin-graphql 2024.04.6, 2023.10.6, 2022.10.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist aimeos/ai-admin-graphql
- Affected
- >= 2022.04.1, < 2022.10.10>= 2023.04.1, < 2023.10.6>= 2024.04.1, < 2024.04.6
- Fixed in
- 2024.04.6, 2022.10.10, 2023.10.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vc7j-99jw-jrqm lists affected ranges: Packagist aimeos/ai-admin-graphql >=2022.04.1 =2023.04.1 =2024.04.1 <2024.04.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L
- EPSS
- CVE-2024-39323: 0.44% estimated exploitation activity in the next 30 days; percentile 38.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
aimeos/ai-admin-graphql is the Aimeos GraphQL API admin interface. Starting in version 2022.04.01 and prior to versions 2022.10.10, 2023.10.6, and 2024.04.6, an improper access control vulnerability allows an editor to modify and take over an admin account in the back end. Versions 2022.10.10, 2023.10.6, and 2024.04.6 fix this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vc7j-99jw-jrqm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-39323 Advisory: aimeos/ai-admin-graphql improper access control vulnerability allows an editor to modify admin account IDs: CVE-2024-39323, GHSA-vc7j-99jw-jrqm Record: https://patchnext.com/advisories/cve-2024-39323 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aimeos/ai-admin-graphql 2024.04.6, 2023.10.6, 2022.10.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist aimeos/ai-admin-graphql: affected >= 2022.04.1, < 2022.10.10; >= 2023.04.1, < 2023.10.6; >= 2024.04.1, < 2024.04.6; fixed in 2024.04.6, 2022.10.10, 2023.10.6 ## Suggested inspection (read-only) - Packagist aimeos/ai-admin-graphql: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aimeos/ai-admin-graphql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vc7j-99jw-jrqm (GitHub-reviewed advisory GHSA-vc7j-99jw-jrqm lists affected ranges: Packagist aimeos/ai-admin-graphql >=2022.04.1 =2023.04.1 =2024.04.1 <2024.04.6) Commands are suggestions: review each one before running it.
Loading voting…