Skip to content

← Actionable
Medium, CVSS 5.5

ai-admin-graphql has a Denial of service vulnerability in SaaS and marketplace setups

CVE-2024-47173GHSA-qxgx-hvg3-v92w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aimeos/ai-admin-graphql 2024.07.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2024-47173: 0.36% estimated exploitation activity in the next 30 days; percentile 29.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

All SaaS and marketplace setups using Aimeos version from 2024.04 up to 2024.07.1 are affected by a potential denial of service attack

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qxgx-hvg3-v92w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47173

Advisory: ai-admin-graphql has a Denial of service vulnerability in SaaS and marketplace setups
IDs: CVE-2024-47173, GHSA-qxgx-hvg3-v92w
Record: https://patchnext.com/advisories/cve-2024-47173 (revision 1, source checked 26 Oct 2026, 14:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aimeos/ai-admin-graphql 2024.07.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist aimeos/ai-admin-graphql: affected >= 2024.04.1, < 2024.07.2; fixed in 2024.07.2

## Suggested inspection (read-only)
- Packagist aimeos/ai-admin-graphql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aimeos/ai-admin-graphql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qxgx-hvg3-v92w (GitHub-reviewed advisory GHSA-qxgx-hvg3-v92w lists affected ranges: Packagist aimeos/ai-admin-graphql >=2024.04.1 <2024.07.2)

Commands are suggestions: review each one before running it.

Loading voting…