Skip to content

← Public intelligence

NuGet package

system.security.cryptography.pkcs

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9NuGetAmendedPublished

    Microsoft Security Advisory CVE-2026-70162 - .NET Denial of Service Vulnerability

    CVE-2026-70162 · GHSA-2fmv-rv2c-59x7

    Affected
    • NuGet system.security.cryptography.pkcs >= 10.0.0, <= 10.0.12; >= 11.0.0-preview.1, <= 11.0.0-rc.1; >= 8.0.0, <= 8.0.1; >= 9.0.0, <= 9.0.20
    Fixed in
    11.0.0-rc.28.0.210.0.139.0.21· Vendor fix available
    Issue
    Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in System.Security.Cryptography.Pkcs. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. On Windows, EnvelopedCms.Decode can perform quadratic work while processing attacker-supplied CMS or PKCS#7 attributes, causing pre-authentication CPU exhaustion. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/454 CVSS Details - Version: 3.1 - Severity: Moderate - Score: 5.9 - Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness: CWE-405 (Asymmetric Resource Consumption (Amplification)) Affected Platforms - Platforms: Windows - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects Microsoft .NET projects that use an affected package version listed below. Package name | Affected version | Patched version…

    Recommended action: Upgrade to 11.0.0-rc.2 (pre-release), 10.0.13, 9.0.21 or 8.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5NuGetAmendedPublished

    Microsoft Security Advisory CVE-2026-84008 - .NET Denial of Service Vulnerability

    CVE-2026-84008 · GHSA-846f-f764-76mx

    Affected
    • NuGet system.security.cryptography.pkcs >= 10.0.0, <= 10.0.12; >= 11.0.0-preview.1, <= 11.0.0-rc.1; >= 8.0.0, <= 8.0.1; >= 9.0.0, <= 9.0.20
    Fixed in
    11.0.0-rc.28.0.210.0.139.0.21· Vendor fix available
    Issue
    Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in System.Security.Cryptography.Pkcs. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. SignedCms.CheckSignature can repeatedly reparse attacker-controlled X.509 data, causing unauthenticated quadratic CPU exhaustion. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/468 CVSS Details - Version: 3.1 - Severity: High - Score: 7.5 - Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness: CWE-407 (Inefficient Algorithmic Complexity) Affected Platforms - Platforms: Windows, Linux, macOS - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects Microsoft .NET projects that use an affected package version listed below. Package name | Affected version | Patched version ------------ | ---------------- |…

    Recommended action: Upgrade to 11.0.0-rc.2 (pre-release), 10.0.13, 9.0.21 or 8.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5NuGetPublished

    .NET Denial of Service vulnerability

    CVE-2023-29331 · GHSA-555c-2p6r-68mm

    Affected
    • NuGet system.security.cryptography.pkcs >= 7.0.0, <= 7.0.1; >= 6.0.0, <= 6.0.2
    Fixed in
    6.0.37.0.2· Vendor fix available
    Issue
    Microsoft Security Advisory CVE-2023-29331: .NET Denial of Service vulnerability <a name="executive-summary"</aExecutive summary Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 7.0 and .NET 6.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET when processing X.509 certificates that may result in Denial of Service. Details: KB5025823 Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/257 <a name="mitigation-factors"</aMitigation factors Microsoft has not identified any mitigating factors for this vulnerability. <a name="affected-software"</aAffected software Any .NET 7.0 application running on .NET 7.0.5 or earlier. Any .NET 6.0 application running on .NET 6.0.16 or earlier. If your application uses the following package versions, ensure you update to the latest version of .NET.…

    Recommended action: Upgrade to 7.0.2 or 6.0.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →