Microsoft Security Advisory CVE-2026-70162 - .NET Denial of Service Vulnerability
CVE-2026-70162GHSA-2fmv-rv2c-59x7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (system.security.cryptography.pkcs 11.0.0-rc.2, 10.0.13, 9.0.21, 8.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet system.security.cryptography.pkcs
- Affected
- >= 10.0.0, <= 10.0.12>= 11.0.0-preview.1, <= 11.0.0-rc.1>= 8.0.0, <= 8.0.1>= 9.0.0, <= 9.0.20
- Fixed in
- 11.0.0-rc.2, 8.0.2, 10.0.13, 9.0.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2fmv-rv2c-59x7 lists affected ranges: NuGet system.security.cryptography.pkcs >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <9.0.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2fmv-rv2c-59x7 lists affected ranges: NuGet system.security.cryptography.pkcs >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <=9.0.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-70162: 0.90% estimated exploitation activity in the next 30 days; percentile 59.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in System.Security.Cryptography.Pkcs. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. On Windows, EnvelopedCms.Decode can perform quadratic work while processing attacker-supplied CMS or PKCS#7 attributes, causing pre-authentication CPU exhaustion. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/454 CVSS Details - Version: 3.1 - Severity: Moderate - Score: 5.9 - Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness: CWE-405 (Asymmetric Resource Consumption (Amplification)) Affected Platforms - Platforms: Windows - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects Microsoft .NET projects that use an affected package version listed below. Package name | Affected version | Patched version…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2fmv-rv2c-59x7
- Revision 1 · created ·
Published from osv record GHSA-2fmv-rv2c-59x7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-70162 Advisory: Microsoft Security Advisory CVE-2026-70162 - .NET Denial of Service Vulnerability IDs: CVE-2026-70162, GHSA-2fmv-rv2c-59x7 Record: https://patchnext.com/advisories/cve-2026-70162 (revision 2, source checked 26 Oct 2026, 17:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: system.security.cryptography.pkcs 11.0.0-rc.2, 10.0.13, 9.0.21, 8.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet system.security.cryptography.pkcs: affected >= 10.0.0, <= 10.0.12; >= 11.0.0-preview.1, <= 11.0.0-rc.1; >= 8.0.0, <= 8.0.1; >= 9.0.0, <= 9.0.20; fixed in 11.0.0-rc.2, 8.0.2, 10.0.13, 9.0.21 ## Suggested inspection (read-only) - NuGet system.security.cryptography.pkcs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on system.security.cryptography.pkcs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2fmv-rv2c-59x7 (OSV record GHSA-2fmv-rv2c-59x7 lists affected ranges: NuGet system.security.cryptography.pkcs >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <9.0.21 (fixed)) - Verified: https://github.com/advisories/GHSA-2fmv-rv2c-59x7 (GitHub-reviewed advisory GHSA-2fmv-rv2c-59x7 lists affected ranges: NuGet system.security.cryptography.pkcs >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <=9.0.20) Commands are suggestions: review each one before running it.
Loading voting…