Skip to content

← Actionable
High, CVSS 7.5amended

Microsoft Security Advisory CVE-2026-84008 - .NET Denial of Service Vulnerability

CVE-2026-84008GHSA-846f-f764-76mx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (system.security.cryptography.pkcs 11.0.0-rc.2, 10.0.13, 9.0.21, 8.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet system.security.cryptography.pkcs

    Affected
    >= 10.0.0, <= 10.0.12>= 11.0.0-preview.1, <= 11.0.0-rc.1>= 8.0.0, <= 8.0.1>= 9.0.0, <= 9.0.20
    Fixed in
    11.0.0-rc.2, 8.0.2, 10.0.13, 9.0.21

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-84008: 0.99% estimated exploitation activity in the next 30 days; percentile 62.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in System.Security.Cryptography.Pkcs. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. SignedCms.CheckSignature can repeatedly reparse attacker-controlled X.509 data, causing unauthenticated quadratic CPU exhaustion. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/468 CVSS Details - Version: 3.1 - Severity: High - Score: 7.5 - Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness: CWE-407 (Inefficient Algorithmic Complexity) Affected Platforms - Platforms: Windows, Linux, macOS - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects Microsoft .NET projects that use an affected package version listed below. Package name | Affected version | Patched version ------------ | ---------------- |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-846f-f764-76mx

  2. Revision 1 · created ·

    Published from osv record GHSA-846f-f764-76mx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-84008

Advisory: Microsoft Security Advisory CVE-2026-84008 - .NET Denial of Service Vulnerability
IDs: CVE-2026-84008, GHSA-846f-f764-76mx
Record: https://patchnext.com/advisories/cve-2026-84008 (revision 2, source checked 26 Oct 2026, 17:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: system.security.cryptography.pkcs 11.0.0-rc.2, 10.0.13, 9.0.21, 8.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet system.security.cryptography.pkcs: affected >= 10.0.0, <= 10.0.12; >= 11.0.0-preview.1, <= 11.0.0-rc.1; >= 8.0.0, <= 8.0.1; >= 9.0.0, <= 9.0.20; fixed in 11.0.0-rc.2, 8.0.2, 10.0.13, 9.0.21

## Suggested inspection (read-only)
- NuGet system.security.cryptography.pkcs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on system.security.cryptography.pkcs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-846f-f764-76mx (OSV record GHSA-846f-f764-76mx lists affected ranges: NuGet system.security.cryptography.pkcs >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <9.0.21 (fixed))
- Verified: https://github.com/advisories/GHSA-846f-f764-76mx (GitHub-reviewed advisory GHSA-846f-f764-76mx lists affected ranges: NuGet system.security.cryptography.pkcs >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <=9.0.20)

Commands are suggestions: review each one before running it.

Loading voting…