Skip to content

← Public intelligence

NuGet package

system.management.automation

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5NuGetPublished

    High severity vulnerability that affects System.Management.Automation

    CVE-2019-1301 · GHSA-62gw-3rmj-wmp2

    Affected
    • NuGet system.management.automation >= 6.2.0, < 6.2.3; >= 6.0.0, < 6.1.6
    Fixed in
    6.2.36.1.6· Vendor fix available
    Issue
    Microsoft Security Advisory CVE-2019-1301: Denial of Service Vulnerability in PowerShell Core Executive Summary A denial of service vulnerability exists when PowerShell Core or .NET Core improperly handles web requests. An attacker who successfully exploited this vulnerability could cause a denial of service against a PowerShell Core scripts. The update addresses the vulnerability by correcting how the .NET Core handles web requests. System administrators are advised to update PowerShell Core to an unaffected version (see affected software.) Discussion Please open a support question to discussion the PowerShell aspects of this advisory. Please use dotnet/announcements#121 for discussion of the .NET aspects this advisory. <a name="affected-software"Affected Software</a The vulnerability affects PowerShell Core prior to the following versions: | PowerShell Core Version | Fixed in | |-------------------------|-------------------| | 6.1 | 6.1.6 | | 6.2 | 6.2.3 | | 7.0 | unaffected | |5 |…

    Recommended action: Upgrade to 6.2.3 or 6.1.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.1NuGetPublished

    System.Management.Automation subject to bypass via script debugging

    CVE-2019-1167 · GHSA-5frh-8cmj-gc59

    Affected
    • NuGet system.management.automation >= 6.2.0, < 6.2.2; >= 6.1.0, < 6.1.5
    Fixed in
    6.1.56.2.2· Vendor fix available
    Issue
    Microsoft Security Advisory CVE-2019-1167: Windows Defender Application Control Security Feature Bypass Vulnerability Microsoft Security Advisory CVE-2019-1167: Windows Defender Application Control Security Feature Bypass Vulnerability Executive Summary A security feature bypass vulnerability exists in Windows Defender Application Control (WDAC) which could allow an attacker to bypass WDAC enforcement. An attacker who successfully exploited this vulnerability could circumvent PowerShell Core Constrained Language Mode on the machine. To exploit the vulnerability, an attacker would first have access to the local machine where PowerShell is running in Constrained Language mode. By doing that an attacker could leverage script debugging to abuse signed modules in an unintended way. The update addresses the vulnerability by correcting how PowerShell functions in Constrained Language Mode. System administrators are advised to update PowerShell Core to an unaffected version (see affected…

    Recommended action: Upgrade to 6.2.2 or 6.1.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →