Skip to content

← Actionable
High, CVSS 7.5

High severity vulnerability that affects System.Management.Automation

CVE-2019-1301GHSA-62gw-3rmj-wmp2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (system.management.automation 6.2.3, 6.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-1301: 5.33% estimated exploitation activity in the next 30 days; percentile 92.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Microsoft Security Advisory CVE-2019-1301: Denial of Service Vulnerability in PowerShell Core Executive Summary A denial of service vulnerability exists when PowerShell Core or .NET Core improperly handles web requests. An attacker who successfully exploited this vulnerability could cause a denial of service against a PowerShell Core scripts. The update addresses the vulnerability by correcting how the .NET Core handles web requests. System administrators are advised to update PowerShell Core to an unaffected version (see affected software.) Discussion Please open a support question to discussion the PowerShell aspects of this advisory. Please use dotnet/announcements#121 for discussion of the .NET aspects this advisory. <a name="affected-software"Affected Software</a The vulnerability affects PowerShell Core prior to the following versions: | PowerShell Core Version | Fixed in | |-------------------------|-------------------| | 6.1 | 6.1.6 | | 6.2 | 6.2.3 | | 7.0 | unaffected | |5 |…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-62gw-3rmj-wmp2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-1301

Advisory: High severity vulnerability that affects System.Management.Automation
IDs: CVE-2019-1301, GHSA-62gw-3rmj-wmp2
Record: https://patchnext.com/advisories/cve-2019-1301 (revision 1, source checked 26 Oct 2026, 17:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: system.management.automation 6.2.3, 6.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet system.management.automation: affected >= 6.2.0, < 6.2.3; >= 6.0.0, < 6.1.6; fixed in 6.2.3, 6.1.6

## Suggested inspection (read-only)
- NuGet system.management.automation: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on system.management.automation.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-62gw-3rmj-wmp2 (GitHub-reviewed advisory GHSA-62gw-3rmj-wmp2 lists affected ranges: NuGet system.management.automation >=6.2.0 =6.0.0 <6.1.6)

Commands are suggestions: review each one before running it.

Loading voting…