Skip to content

← Public intelligence

Maven package

xerces:xercesImpl

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Missing XML Validation in Apache Xerces2

    CVE-2013-4002 · GHSA-7j4h-8wpf-rqfh

    Affected
    • Maven xerces:xercesImpl < 2.12.0
    Fixed in
    2.12.0· Vendor fix available
    Issue
    XMLscanner.java in Apache Xerces2 Java Parser before 2.12.0, as used in the Java Runtime Environment (JRE) in IBM Java 5.0 before 5.0 SR16-FP3, 6 before 6 SR14, 6.0.1 before 6.0.1 SR6, and 7 before 7 SR5 as well as Oracle Java SE 7u40 and earlier, Java SE 6u60 and earlier, Java SE 5.0u51 and earlier, JRockit R28.2.8 and earlier, JRockit R27.7.6 and earlier, Java SE Embedded 7u40 and earlier, and possibly other products allows remote attackers to cause a denial of service via vectors related to XML attribute names.

    Recommended action: Upgrade to 2.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.3MavenPublished

    Improper Input Validation in Xerces

    CVE-2020-14338 · GHSA-w4jq-qh47-hvjq

    Affected
    • Maven xerces:xercesImpl <= 2.12.0.sp2
    Fixed in
    2.12.0.sp3· Vendor fix available
    Issue
    A flaw was found in Wildfly's implementation of Xerces, specifically in the way the XMLSchemaValidator class in the JAXP component of Wildfly enforced the "use-grammar-pool-only" feature. This flaw allows a specially-crafted XML file to manipulate the validation process in certain cases. This issue is the same flaw as CVE-2020-14621, which affected OpenJDK, and uses a similar code. All xerces jboss versions before 2.12.0.SP3.

    Recommended action: Upgrade to 2.12.0.sp3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.5MavenPublished

    Infinite Loop in Apache Xerces Java

    CVE-2022-23437 · GHSA-h65f-jvqw-m9fj

    Affected
    • Maven xerces:xercesImpl < 2.12.2
    Fixed in
    2.12.2· Vendor fix available
    Issue
    There's a vulnerability within the Apache Xerces Java (XercesJ) XML parser when handling specially crafted XML document payloads. This causes, the XercesJ XML parser to wait in an infinite loop, which may sometimes consume system resources for prolonged duration. This vulnerability is present within XercesJ version 2.12.1 and the previous versions.

    Recommended action: Upgrade to 2.12.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Denial of service in Apache Xerces2

    CVE-2012-0881 · GHSA-vmqm-g3vh-847m

    Affected
    • Maven xerces:xercesImpl < 2.12.0
    Fixed in
    2.12.0· Vendor fix available
    Issue
    Apache Xerces2 Java Parser before 2.12.0 allows remote attackers to cause a denial of service (CPU consumption) via a crafted message to an XML service, which triggers hash table collisions.

    Recommended action: Upgrade to 2.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. UnratedMavenPublished

    Denial of service in Apache Xerces2

    CVE-2009-2625 · GHSA-334p-wv2m-w3vp

    Affected
    • Maven xerces:xercesImpl < 2.10.0
    Fixed in
    2.10.0· Vendor fix available
    Issue
    XMLScanner.java in Apache Xerces2 Java, as used in Sun Java Runtime Environment (JRE) in JDK and JRE 6 before Update 15 and JDK and JRE 5.0 before Update 20, and in other products, allows remote attackers to cause a denial of service (infinite loop and application hang) via malformed XML input, as demonstrated by the Codenomicon XML fuzzing framework.

    Recommended action: Upgrade to 2.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →