Improper Input Validation in Xerces
CVE-2020-14338GHSA-w4jq-qh47-hvjq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (xerces:xercesImpl 2.12.0.sp3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven xerces:xercesImpl
- Affected
- <= 2.12.0.sp2
- Fixed in
- 2.12.0.sp3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w4jq-qh47-hvjq lists affected ranges: Maven xerces:xercesImpl >=0 <=2.12.0.sp2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2020-14338: 1.29% estimated exploitation activity in the next 30 days; percentile 70.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in Wildfly's implementation of Xerces, specifically in the way the XMLSchemaValidator class in the JAXP component of Wildfly enforced the "use-grammar-pool-only" feature. This flaw allows a specially-crafted XML file to manipulate the validation process in certain cases. This issue is the same flaw as CVE-2020-14621, which affected OpenJDK, and uses a similar code. All xerces jboss versions before 2.12.0.SP3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w4jq-qh47-hvjq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-14338 Advisory: Improper Input Validation in Xerces IDs: CVE-2020-14338, GHSA-w4jq-qh47-hvjq Record: https://patchnext.com/advisories/cve-2020-14338 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: xerces:xercesImpl 2.12.0.sp3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven xerces:xercesImpl: affected <= 2.12.0.sp2; fixed in 2.12.0.sp3 ## Suggested inspection (read-only) - Maven xerces:xercesImpl: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on xerces:xercesImpl. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w4jq-qh47-hvjq (GitHub-reviewed advisory GHSA-w4jq-qh47-hvjq lists affected ranges: Maven xerces:xercesImpl >=0 <=2.12.0.sp2) Commands are suggestions: review each one before running it.
Loading voting…