Denial of service in Apache Xerces2
CVE-2009-2625GHSA-334p-wv2m-w3vp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (xerces:xercesImpl 2.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven xerces:xercesImpl
- Affected
- < 2.10.0
- Fixed in
- 2.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-334p-wv2m-w3vp lists affected ranges: Maven xerces:xercesImpl >=0 <2.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2009-2625: 30.38% estimated exploitation activity in the next 30 days; percentile 98.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
XMLScanner.java in Apache Xerces2 Java, as used in Sun Java Runtime Environment (JRE) in JDK and JRE 6 before Update 15 and JDK and JRE 5.0 before Update 20, and in other products, allows remote attackers to cause a denial of service (infinite loop and application hang) via malformed XML input, as demonstrated by the Codenomicon XML fuzzing framework.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-334p-wv2m-w3vp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-2625 Advisory: Denial of service in Apache Xerces2 IDs: CVE-2009-2625, GHSA-334p-wv2m-w3vp Record: https://patchnext.com/advisories/cve-2009-2625 (revision 1, source checked 26 Oct 2026, 16:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: xerces:xercesImpl 2.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven xerces:xercesImpl: affected < 2.10.0; fixed in 2.10.0 ## Suggested inspection (read-only) - Maven xerces:xercesImpl: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on xerces:xercesImpl. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-334p-wv2m-w3vp (GitHub-reviewed advisory GHSA-334p-wv2m-w3vp lists affected ranges: Maven xerces:xercesImpl >=0 <2.10.0) Commands are suggestions: review each one before running it.
Loading voting…