Skip to content

← Public intelligence

Maven package

org.wildfly.core:wildfly-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    WildFly improper RBAC permission

    CVE-2025-23367 · GHSA-qr6x-62gq-4ccp

    Affected
    • Maven org.wildfly.core:wildfly-server < 27.0.1.Final; >= 28.0.0.Beta1, <= 28.0.0.Beta1
    Fixed in
    28.0.0.Beta227.0.1.Final· Vendor fix available
    Issue
    A flaw was found in the Wildfly Server Role Based Access Control (RBAC) provider. When authorization to control management operations is secured using the Role Based Access Control provider, a user without the required privileges can suspend or resume the server. A user with a Monitor or Auditor role is supposed to have only read access permissions and should not be able to suspend the server. The vulnerability is caused by the Suspend and Resume handlers not performing authorization checks to validate whether the current user has the required permissions to proceed with the action. Impact Standalone server (Domain mode is not affected) with use access control enabled with RBAC provider can be suspended or resumed by unauthorized users. When a server is suspended, the server will stop receiving user requests. The resume handle does the opposite; it will cause a suspended server to start accepting user requests. Patches Fixed in WildFly Core 27.0.1.Final Workarounds No workaround…

    Recommended action: Upgrade to 28.0.0.Beta2 or 27.0.1.Final by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Low, CVSS 3.3MavenPublished

    wildfly-core allows user with access to management interface to access vault expression, retrieve item from vault

    CVE-2021-3644 · GHSA-w88m-2936-rmxr

    Affected
    • Maven org.wildfly.core:wildfly-server < 16.0.1.Final; >= 17.0.0.Beta2, < 17.0.0.Beta3
    Fixed in
    17.0.0.Beta316.0.1.Final· Vendor fix available
    Issue
    A flaw was found in wildfly-core in all versions. If a vault expression is in the form of a single attribute that contains multiple expressions, a user who was granted access to the management interface can potentially access a vault expression they should not be able to access and possibly retrieve the item which was stored in the vault. The highest threat from this vulnerability is data confidentiality and integrity.

    Recommended action: Upgrade to 17.0.0.Beta3 or 16.0.1.Final by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.5MavenPublished

    Improper Limitation of a Pathname to a Restricted Directory in WildFly

    CVE-2018-10862 · GHSA-w8r2-5j8x-x8j6

    Affected
    • Maven org.wildfly.core:wildfly-server <= 6.0.0.Alpha2
    Fixed in
    6.0.0.Alpha3· Vendor fix available
    Issue
    WildFly Core before version 6.0.0.Alpha3 does not properly validate file paths in .war archives, allowing for the extraction of crafted .war archives to overwrite arbitrary files. This is an instance of the 'Zip Slip' vulnerability.

    Recommended action: Upgrade to 6.0.0.Alpha3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →