Skip to content

← Actionable
Low, CVSS 3.3

wildfly-core allows user with access to management interface to access vault expression, retrieve item from vault

CVE-2021-3644GHSA-w88m-2936-rmxr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.wildfly.core:wildfly-server 17.0.0.Beta3, 16.0.1.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2021-3644: 0.98% estimated exploitation activity in the next 30 days; percentile 62.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in wildfly-core in all versions. If a vault expression is in the form of a single attribute that contains multiple expressions, a user who was granted access to the management interface can potentially access a vault expression they should not be able to access and possibly retrieve the item which was stored in the vault. The highest threat from this vulnerability is data confidentiality and integrity.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w88m-2936-rmxr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3644

Advisory: wildfly-core allows user with access to management interface to access vault expression, retrieve item from vault
IDs: CVE-2021-3644, GHSA-w88m-2936-rmxr
Record: https://patchnext.com/advisories/cve-2021-3644 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.wildfly.core:wildfly-server 17.0.0.Beta3, 16.0.1.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.wildfly.core:wildfly-server: affected < 16.0.1.Final; >= 17.0.0.Beta2, < 17.0.0.Beta3; fixed in 17.0.0.Beta3, 16.0.1.Final

## Suggested inspection (read-only)
- Maven org.wildfly.core:wildfly-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.wildfly.core:wildfly-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w88m-2936-rmxr (GitHub-reviewed advisory GHSA-w88m-2936-rmxr lists affected ranges: Maven org.wildfly.core:wildfly-server >=0 =17.0.0.Beta2 <17.0.0.Beta3)

Commands are suggestions: review each one before running it.

Loading voting…