WildFly improper RBAC permission
CVE-2025-23367GHSA-qr6x-62gq-4ccp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.wildfly.core:wildfly-server 28.0.0.Beta2, 27.0.1.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.wildfly.core:wildfly-server
- Affected
- < 27.0.1.Final>= 28.0.0.Beta1, <= 28.0.0.Beta1
- Fixed in
- 28.0.0.Beta2, 27.0.1.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qr6x-62gq-4ccp lists affected ranges: Maven org.wildfly.core:wildfly-server >=0 =28.0.0.Beta1 <=28.0.0.Beta1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-23367: 0.77% estimated exploitation activity in the next 30 days; percentile 55.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in the Wildfly Server Role Based Access Control (RBAC) provider. When authorization to control management operations is secured using the Role Based Access Control provider, a user without the required privileges can suspend or resume the server. A user with a Monitor or Auditor role is supposed to have only read access permissions and should not be able to suspend the server. The vulnerability is caused by the Suspend and Resume handlers not performing authorization checks to validate whether the current user has the required permissions to proceed with the action. Impact Standalone server (Domain mode is not affected) with use access control enabled with RBAC provider can be suspended or resumed by unauthorized users. When a server is suspended, the server will stop receiving user requests. The resume handle does the opposite; it will cause a suspended server to start accepting user requests. Patches Fixed in WildFly Core 27.0.1.Final Workarounds No workaround…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qr6x-62gq-4ccp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-23367 Advisory: WildFly improper RBAC permission IDs: CVE-2025-23367, GHSA-qr6x-62gq-4ccp Record: https://patchnext.com/advisories/cve-2025-23367 (revision 1, source checked 26 Oct 2026, 16:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.wildfly.core:wildfly-server 28.0.0.Beta2, 27.0.1.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.wildfly.core:wildfly-server: affected < 27.0.1.Final; >= 28.0.0.Beta1, <= 28.0.0.Beta1; fixed in 28.0.0.Beta2, 27.0.1.Final ## Suggested inspection (read-only) - Maven org.wildfly.core:wildfly-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.wildfly.core:wildfly-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qr6x-62gq-4ccp (GitHub-reviewed advisory GHSA-qr6x-62gq-4ccp lists affected ranges: Maven org.wildfly.core:wildfly-server >=0 =28.0.0.Beta1 <=28.0.0.Beta1) Commands are suggestions: review each one before running it.
Loading voting…