Skip to content

← Public intelligence

Maven package

org.springframework.security:spring-security-oauth2-authorization-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Spring Security OAuth2 Authorization Server: Authorization endpoint performs insufficient validation of the request_uri parameter

    CVE-2026-41008 · GHSA-4r8w-73jc-3m7q

    Affected
    • Maven org.springframework.security:spring-security-oauth2-authorization-server >= 7.0.0, <= 7.0.5; >= 1.5.0, <= 1.5.7
    Fixed in
    1.5.87.0.6· Vendor fix available
    Issue
    Spring Security Authorization Server's authorization endpoint performs insufficient validation of the requesturi parameter. An attacker can craft a malicious authorization request containing an invalid requesturi and an arbitrary, unvalidated redirecturi, which can lead to an Open Redirect vulnerability. Affected versions: Spring Security 7.0.0 through 7.0.5. Spring Authorization Server 1.5.0 through 1.5.7.

    Recommended action: Upgrade to 7.0.6 or 1.5.8 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1MavenPublished

    Improper Authentication in Spring Authorization Server

    CVE-2024-22258 · GHSA-x637-x8p3-5p22

    Affected
    • Maven org.springframework.security:spring-security-oauth2-authorization-server < 1.1.6; >= 1.2.0, < 1.2.3
    Fixed in
    1.2.31.1.6· Vendor fix available
    Issue
    Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients. Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant. An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

    Recommended action: Upgrade to 1.2.3 or 1.1.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →