Skip to content

← Actionable
Medium, CVSS 6.1

Spring Security OAuth2 Authorization Server: Authorization endpoint performs insufficient validation of the request_uri parameter

CVE-2026-41008GHSA-4r8w-73jc-3m7q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-oauth2-authorization-server 7.0.6, 1.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4r8w-73jc-3m7q lists affected ranges: Maven org.springframework.security:spring-security-oauth2-authorization-server >=7.0.0 =1.5.0 <=1.5.7

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-41008: 0.18% estimated exploitation activity in the next 30 days; percentile 7.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spring Security Authorization Server's authorization endpoint performs insufficient validation of the requesturi parameter. An attacker can craft a malicious authorization request containing an invalid requesturi and an arbitrary, unvalidated redirecturi, which can lead to an Open Redirect vulnerability. Affected versions: Spring Security 7.0.0 through 7.0.5. Spring Authorization Server 1.5.0 through 1.5.7.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4r8w-73jc-3m7q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41008

Advisory: Spring Security OAuth2 Authorization Server: Authorization endpoint performs insufficient validation of the request_uri parameter
IDs: CVE-2026-41008, GHSA-4r8w-73jc-3m7q
Record: https://patchnext.com/advisories/cve-2026-41008 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-oauth2-authorization-server 7.0.6, 1.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.security:spring-security-oauth2-authorization-server: affected >= 7.0.0, <= 7.0.5; >= 1.5.0, <= 1.5.7; fixed in 1.5.8, 7.0.6

## Suggested inspection (read-only)
- Maven org.springframework.security:spring-security-oauth2-authorization-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.security:spring-security-oauth2-authorization-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4r8w-73jc-3m7q (GitHub-reviewed advisory GHSA-4r8w-73jc-3m7q lists affected ranges: Maven org.springframework.security:spring-security-oauth2-authorization-server >=7.0.0 =1.5.0 <=1.5.7)

Commands are suggestions: review each one before running it.

Loading voting…