Skip to content

← Actionable
Medium, CVSS 6.1

Improper Authentication in Spring Authorization Server

CVE-2024-22258GHSA-x637-x8p3-5p22

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-oauth2-authorization-server 1.2.3, 1.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-x637-x8p3-5p22 lists affected ranges: Maven org.springframework.security:spring-security-oauth2-authorization-server >=0 =1.2.0 <1.2.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-22258: 0.53% estimated exploitation activity in the next 30 days; percentile 44.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients. Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant. An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x637-x8p3-5p22

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-22258

Advisory: Improper Authentication in Spring Authorization Server
IDs: CVE-2024-22258, GHSA-x637-x8p3-5p22
Record: https://patchnext.com/advisories/cve-2024-22258 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-oauth2-authorization-server 1.2.3, 1.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.security:spring-security-oauth2-authorization-server: affected < 1.1.6; >= 1.2.0, < 1.2.3; fixed in 1.2.3, 1.1.6

## Suggested inspection (read-only)
- Maven org.springframework.security:spring-security-oauth2-authorization-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.security:spring-security-oauth2-authorization-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x637-x8p3-5p22 (GitHub-reviewed advisory GHSA-x637-x8p3-5p22 lists affected ranges: Maven org.springframework.security:spring-security-oauth2-authorization-server >=0 =1.2.0 <1.2.3)

Commands are suggestions: review each one before running it.

Loading voting…