Skip to content

← Public intelligence

Maven package

org.ops4j.pax.logging:pax-logging-log4j2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.6MavenPublished

    Improper Input Validation and Injection in Apache Log4j2

    CVE-2021-44832 · GHSA-8489-44mv-ggj8

    Affected
    • Maven org.ops4j.pax.logging:pax-logging-log4j2 >= 1.8.0, < 1.9.2; >= 1.10.0, < 1.10.9; >= 1.11.0, < 1.11.13; >= 2.0.0, < 2.0.14
    Fixed in
    1.9.21.10.91.11.132.0.14· Vendor fix available
    Issue
    Apache Log4j2 versions 2.0-beta7 through 2.17.0 (excluding security fix releases 2.3.2 and 2.12.4) are vulnerable to an attack where an attacker with permission to modify the logging configuration file can construct a malicious configuration using a JDBC Appender with a data source referencing a JNDI URI which can execute remote code. This issue is fixed by limiting JNDI data source names to the java protocol in Log4j2 versions 2.17.1, 2.12.4, and 2.3.2. Affected packages Only the org.apache.logging.log4j:log4j-core package is directly affected by this vulnerability. The org.apache.logging.log4j:log4j-api should be kept at the same version as the org.apache.logging.log4j:log4j-core package to ensure compatability if in use. This issue does not impact default configurations of Log4j2 and requires an attacker to have control over the Log4j2 configuration, which reduces the likelihood of being exploited.

    Recommended action: Upgrade to 2.0.14, 1.11.13, 1.10.9 or 1.9.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.6MavenPublished

    Apache Log4j2 vulnerable to Improper Input Validation and Uncontrolled Recursion

    CVE-2021-45105 · GHSA-p6xc-xr62-6r2g

    Affected
    • Maven org.ops4j.pax.logging:pax-logging-log4j2 >= 1.8.0, < 1.9.2; >= 1.10.0, < 1.10.9; >= 1.11.0, < 1.11.12; >= 2.0.0, < 2.0.13
    Fixed in
    2.0.131.9.21.10.91.11.12· Vendor fix available
    Issue
    Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0 and 2.12.3. Affected packages Only the org.apache.logging.log4j:log4j-core package is directly affected by this vulnerability. The org.apache.logging.log4j:log4j-api should be kept at the same version as the org.apache.logging.log4j:log4j-core package to ensure compatability if in use.

    Recommended action: Upgrade to 2.0.13, 1.11.12, 1.10.9 or 1.9.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.0Exploited · CISA KEVMavenPublished

    Incomplete fix for Apache Log4j vulnerability

    CVE-2021-45046 · GHSA-7rjr-3q55-vv33

    Affected
    • Maven org.ops4j.pax.logging:pax-logging-log4j2 >= 1.8.0, < 1.9.2; >= 1.10.0, < 1.10.8; >= 1.11.0, < 1.11.11; >= 2.0.0, < 2.0.12
    Fixed in
    1.10.81.9.21.11.112.0.12· Vendor fix available
    Issue
    Impact The fix to address CVE-2021-44228 in Apache Log4j 2.15.0 was incomplete in certain non-default configurations. This could allow attackers with control over Thread Context Map (MDC) input data when the logging configuration uses a non-default Pattern Layout with either a Context Lookup (for example, $${ctx:loginId}) or a Thread Context Map pattern (%X, %mdc, or %MDC) to craft malicious input data using a JNDI Lookup pattern resulting in a remote code execution (RCE) attack. Affected packages Only the org.apache.logging.log4j:log4j-core package is directly affected by this vulnerability. The org.apache.logging.log4j:log4j-api should be kept at the same version as the org.apache.logging.log4j:log4j-core package to ensure compatability if in use. Mitigation Log4j 2.16.0 fixes this issue by removing support for message lookup patterns and disabling JNDI functionality by default. This issue can be mitigated in prior releases (< 2.16.0) by removing the JndiLookup class from the…

    Recommended action: Upgrade to 2.0.12, 1.11.11, 1.10.8 or 1.9.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:cisa.gov (1)github.com (2)Source checked Evidence →
  4. UnratedMavenPublished

    Remote code injection in Log4j (through pax-logging-log4j2)

    GHSA-xxfh-x98p-j8fr

    Affected
    • Maven org.ops4j.pax.logging:pax-logging-log4j2 >= 2.0.0, < 2.0.11; < 1.11.10
    Fixed in
    1.11.102.0.11· Vendor fix available
    Issue
    Impact Remote Code Execution. Patches Users of pax-logging 1.11.9 should update to 1.11.10. Users of pax-logging 2.0.10 should update to 2.0.11. Workarounds Set system property -Dlog4j2.formatMsgNoLookups=true References https://github.com/advisories/GHSA-jfh8-c2jp-5v3q

    Recommended action: Upgrade to 2.0.11 or 1.11.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →