Incomplete fix for Apache Log4j vulnerability
CVE-2021-45046GHSA-7rjr-3q55-vv33
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.ops4j.pax.logging:pax-logging-log4j2 2.0.12, 1.11.11, 1.10.8, 1.9.2; org.apache.logging.log4j:log4j-core 2.16.0, 2.12.2, 2.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.ops4j.pax.logging:pax-logging-log4j2
- Affected
- >= 1.8.0, < 1.9.2>= 1.10.0, < 1.10.8>= 1.11.0, < 1.11.11>= 2.0.0, < 2.0.12
- Fixed in
- 1.10.8, 1.9.2, 1.11.11, 2.0.12
Maven org.apache.logging.log4j:log4j-core
- Affected
- >= 2.13.0, < 2.16.0>= 2.4.0, < 2.12.2< 2.3.1
- Fixed in
- 2.16.0, 2.12.2, 2.3.1
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2021-45046 to the Known Exploited Vulnerabilities catalog on 2023-05-01.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2023-05-01).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7rjr-3q55-vv33 lists affected ranges: Maven org.apache.logging.log4j:log4j-core >=2.13.0 =2.4.0 =0 =1.8.0 =1.10.0 =1.11.0 =2.0.0 <2.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2021-45046: 99.98% estimated exploitation activity in the next 30 days; percentile 99.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The fix to address CVE-2021-44228 in Apache Log4j 2.15.0 was incomplete in certain non-default configurations. This could allow attackers with control over Thread Context Map (MDC) input data when the logging configuration uses a non-default Pattern Layout with either a Context Lookup (for example, $${ctx:loginId}) or a Thread Context Map pattern (%X, %mdc, or %MDC) to craft malicious input data using a JNDI Lookup pattern resulting in a remote code execution (RCE) attack. Affected packages Only the org.apache.logging.log4j:log4j-core package is directly affected by this vulnerability. The org.apache.logging.log4j:log4j-api should be kept at the same version as the org.apache.logging.log4j:log4j-core package to ensure compatability if in use. Mitigation Log4j 2.16.0 fixes this issue by removing support for message lookup patterns and disabling JNDI functionality by default. This issue can be mitigated in prior releases (< 2.16.0) by removing the JndiLookup class from the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7rjr-3q55-vv33
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-45046 Advisory: Incomplete fix for Apache Log4j vulnerability IDs: CVE-2021-45046, GHSA-7rjr-3q55-vv33 Record: https://patchnext.com/advisories/cve-2021-45046 (revision 1, source checked 26 Oct 2026, 16:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: org.ops4j.pax.logging:pax-logging-log4j2 2.0.12, 1.11.11, 1.10.8, 1.9.2; org.apache.logging.log4j:log4j-core 2.16.0, 2.12.2, 2.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.ops4j.pax.logging:pax-logging-log4j2: affected >= 1.8.0, < 1.9.2; >= 1.10.0, < 1.10.8; >= 1.11.0, < 1.11.11; >= 2.0.0, < 2.0.12; fixed in 1.10.8, 1.9.2, 1.11.11, 2.0.12 - Maven org.apache.logging.log4j:log4j-core: affected >= 2.13.0, < 2.16.0; >= 2.4.0, < 2.12.2; < 2.3.1; fixed in 2.16.0, 2.12.2, 2.3.1 ## Suggested inspection (read-only) - Maven org.ops4j.pax.logging:pax-logging-log4j2: check the installed version with your package manager. - Maven org.apache.logging.log4j:log4j-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.ops4j.pax.logging:pax-logging-log4j2, org.apache.logging.log4j:log4j-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2021-45046 to the Known Exploited Vulnerabilities catalog on 2023-05-01.) - Verified: https://github.com/advisories/GHSA-7rjr-3q55-vv33 (GitHub-reviewed advisory GHSA-7rjr-3q55-vv33 lists affected ranges: Maven org.apache.logging.log4j:log4j-core >=2.13.0 =2.4.0 =0 =1.8.0 =1.10.0 =1.11.0 =2.0.0 <2.0.12) Commands are suggestions: review each one before running it.
Loading voting…