Apache Log4j2 vulnerable to Improper Input Validation and Uncontrolled Recursion
CVE-2021-45105GHSA-p6xc-xr62-6r2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.ops4j.pax.logging:pax-logging-log4j2 2.0.13, 1.11.12, 1.10.9, 1.9.2; org.apache.logging.log4j:log4j-core 2.17.0, 2.12.3, 2.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.ops4j.pax.logging:pax-logging-log4j2
- Affected
- >= 1.8.0, < 1.9.2>= 1.10.0, < 1.10.9>= 1.11.0, < 1.11.12>= 2.0.0, < 2.0.13
- Fixed in
- 2.0.13, 1.9.2, 1.10.9, 1.11.12
Maven org.apache.logging.log4j:log4j-core
- Affected
- >= 2.4.0, < 2.12.3>= 2.13.0, < 2.17.0< 2.3.1
- Fixed in
- 2.17.0, 2.12.3, 2.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p6xc-xr62-6r2g lists affected ranges: Maven org.apache.logging.log4j:log4j-core >=2.4.0 =2.13.0 =0 =1.8.0 =1.10.0 =1.11.0 =2.0.0 <2.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- EPSS
- CVE-2021-45105: 100.00% estimated exploitation activity in the next 30 days; percentile 99.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0 and 2.12.3. Affected packages Only the org.apache.logging.log4j:log4j-core package is directly affected by this vulnerability. The org.apache.logging.log4j:log4j-api should be kept at the same version as the org.apache.logging.log4j:log4j-core package to ensure compatability if in use.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p6xc-xr62-6r2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-45105 Advisory: Apache Log4j2 vulnerable to Improper Input Validation and Uncontrolled Recursion IDs: CVE-2021-45105, GHSA-p6xc-xr62-6r2g Record: https://patchnext.com/advisories/cve-2021-45105 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.ops4j.pax.logging:pax-logging-log4j2 2.0.13, 1.11.12, 1.10.9, 1.9.2; org.apache.logging.log4j:log4j-core 2.17.0, 2.12.3, 2.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.ops4j.pax.logging:pax-logging-log4j2: affected >= 1.8.0, < 1.9.2; >= 1.10.0, < 1.10.9; >= 1.11.0, < 1.11.12; >= 2.0.0, < 2.0.13; fixed in 2.0.13, 1.9.2, 1.10.9, 1.11.12 - Maven org.apache.logging.log4j:log4j-core: affected >= 2.4.0, < 2.12.3; >= 2.13.0, < 2.17.0; < 2.3.1; fixed in 2.17.0, 2.12.3, 2.3.1 ## Suggested inspection (read-only) - Maven org.ops4j.pax.logging:pax-logging-log4j2: check the installed version with your package manager. - Maven org.apache.logging.log4j:log4j-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.ops4j.pax.logging:pax-logging-log4j2, org.apache.logging.log4j:log4j-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p6xc-xr62-6r2g (GitHub-reviewed advisory GHSA-p6xc-xr62-6r2g lists affected ranges: Maven org.apache.logging.log4j:log4j-core >=2.4.0 =2.13.0 =0 =1.8.0 =1.10.0 =1.11.0 =2.0.0 <2.0.13) Commands are suggestions: review each one before running it.
Loading voting…