Skip to content

← Public intelligence

Maven package

org.openidentityplatform.openam:openam-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.0MavenAmendedPublished

    OpenAM Insecure SSO Cookie Initialization

    CVE-2026-53660 · GHSA-fpmh-vx4h-xc33

    Affected
    • Maven org.openidentityplatform.openam:openam-core < 16.1.1
    Fixed in
    16.1.1· Vendor fix available
    Issue
    Description An Insecure Default Initialization of Resource (CWE-1188) issue in the OpenAM default configuration ships the `iPlanetDirectoryPro` SSO cookie with `HttpOnly=false`. Also, the `iPlanetDirectoryPro` SSO cookie is used as a CSRF token in OAuth/OIDC flows. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1. Impact A single click on an attacker link may yield full SSO session theft of any authenticated console user when chained with any other same-origin XSS in the OpenAM origin. The missing `SameSite` default also widens the CSRF surface. Also, because the consent flow reuses the SSO cookie as its CSRF token, any XSS in the OpenAM origin both steals the session and completes attacker-driven OAuth consent grants in one step. Patch This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.

    Recommended action: Upgrade to 16.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    OpenAM: Unauthenticated Remote Code Execution via Class.forName in AuthXMLUtils.createCustomCallback

    CVE-2026-62379 · GHSA-wg5r-wc3x-39vc

    Affected
    • Maven org.openidentityplatform.openam:openam-core <= 16.1.1
    Fixed in
    16.1.2· Vendor fix available
    Issue
    A pre-authentication remote code execution vulnerability affects OpenAM. The remote authentication endpoint (/authservice, PLL) accepts an XML element that names an arbitrary Java class, which the server then loads and instantiates without validation. On a default configuration this is reachable without authentication and allows an attacker to run code on the server. Impact Unauthenticated remote code execution / full server compromise on any OpenAM instance with default settings. Affected All releases up to and including 16.1.1 (the defect predates the Open Identity Platform fork). Remediation Upgrade to 16.1.2. The fix resolves the class named in a <CustomCallback element without running its static initialisers and rejects it unless it implements DSAMECallbackInterface, and it constrains deserialisation of the serialised Subject value to a class allowlist. Interim mitigation If you cannot upgrade immediately: - Restrict or block external network access to /authservice. This…

    Recommended action: Upgrade to 16.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.5MavenAmendedPublished

    OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC

    CVE-2026-45048 · GHSA-vvhj-w2jq-263q

    Affected
    • Maven org.openidentityplatform.openam:openam-core < 16.1.1
    Fixed in
    16.1.1· Vendor fix available
    Issue
    Description An insufficient authorization (CWE-285) and information exposure (CWE-200) issue in OpenAM's session management endpoint allows a low-privileged authenticated user to retrieve active session credentials belonging to other users, including those with higher privileges. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1. This may be related to CVE-2021-4201, a similar issue patched in ForgeRock Access Management, a separate product sharing a common codebase ancestry. Impact OpenAM Community Edition deployments through version 16.0.6 using stateful session storage and exposing the session management endpoint are potentially affected. The endpoint does not enforce ownership or privilege checks when querying session information, meaning an authenticated user may retrieve active session credentials for arbitrary users. Successful exploitation requires a valid low-privilege session and knowledge of a target user's…

    Recommended action: Upgrade to 16.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  4. Medium, CVSS 6.2MavenAmendedPublished

    OpenAM Authenticated Server-Side Request Forgery (SSRF) via /sessionservice

    CVE-2026-44202 · GHSA-c556-q2mh-477v

    Affected
    • Maven org.openidentityplatform.openam:openam-core < 16.1.1
    Fixed in
    16.1.1· Vendor fix available
    Issue
    OpenAM (Open Identity Platform) is an open-source Identity and Access Management (IAM) platform derived from ForgeRock OpenAM, providing SSO, OAuth2, SAML, and OpenID Connect capabilities. It is widely deployed in enterprise environments as a central authentication gateway. The `/sessionservice` endpoint, used for internal session management operations, does not sufficiently restrict the URLs that authenticated users may register for session event notifications. Under certain conditions, this may result in outbound server-side requests to attacker-controlled destinations, potentially exposing session-related data. This behavior results in a server-side request forgery (SSRF) vulnerability, where an authenticated attacker can trigger outbound requests to arbitrary destinations. Credit Discovered by JD-Security SHENYI Team

    Recommended action: Upgrade to 16.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  5. Medium, CVSS 5.3MavenPublished

    NT auth module vulnerability in OpenAM

    CVE-2022-34298 · GHSA-px3r-27qc-hx5g

    Affected
    • Maven org.openidentityplatform.openam:openam-core < 14.6.6
    Fixed in
    14.6.6· Vendor fix available
    Issue
    The NT auth module in OpenAM before 14.6.6 allows a "replace Samba username attack."

    Recommended action: Upgrade to 14.6.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →