OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC
CVE-2026-45048GHSA-vvhj-w2jq-263q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.openam:openam-core 16.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openidentityplatform.openam:openam-core
- Affected
- < 16.1.1
- Fixed in
- 16.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vvhj-w2jq-263q lists affected ranges: Maven org.openidentityplatform.openam:openam-core >=0 <=16.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vvhj-w2jq-263q lists affected ranges: Maven org.openidentityplatform.openam:openam-core >=0 <16.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-45048: 0.43% estimated exploitation activity in the next 30 days; percentile 37.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Description An insufficient authorization (CWE-285) and information exposure (CWE-200) issue in OpenAM's session management endpoint allows a low-privileged authenticated user to retrieve active session credentials belonging to other users, including those with higher privileges. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1. This may be related to CVE-2021-4201, a similar issue patched in ForgeRock Access Management, a separate product sharing a common codebase ancestry.
Impact OpenAM Community Edition deployments through version 16.0.6 using stateful session storage and exposing the session management endpoint are potentially affected. The endpoint does not enforce ownership or privilege checks when querying session information, meaning an authenticated user may retrieve active session credentials for arbitrary users. Successful exploitation requires a valid low-privilege session and knowledge of a target user's…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-vvhj-w2jq-263q
- Revision 2 · amended ·
Amended from ghsa record GHSA-vvhj-w2jq-263q
- Revision 1 · created ·
Published from ghsa record GHSA-vvhj-w2jq-263q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45048 Advisory: OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC IDs: CVE-2026-45048, GHSA-vvhj-w2jq-263q Record: https://patchnext.com/advisories/cve-2026-45048 (revision 3, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.openam:openam-core 16.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openidentityplatform.openam:openam-core: affected < 16.1.1; fixed in 16.1.1 ## Suggested inspection (read-only) - Maven org.openidentityplatform.openam:openam-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openidentityplatform.openam:openam-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vvhj-w2jq-263q (GitHub-reviewed advisory GHSA-vvhj-w2jq-263q lists affected ranges: Maven org.openidentityplatform.openam:openam-core >=0 <=16.0.6) - Verified: https://osv.dev/vulnerability/GHSA-vvhj-w2jq-263q (OSV record GHSA-vvhj-w2jq-263q lists affected ranges: Maven org.openidentityplatform.openam:openam-core >=0 <16.1.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…