OpenAM Authenticated Server-Side Request Forgery (SSRF) via /sessionservice
CVE-2026-44202GHSA-c556-q2mh-477v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.openam:openam-core 16.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openidentityplatform.openam:openam-core
- Affected
- < 16.1.1
- Fixed in
- 16.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c556-q2mh-477v lists affected ranges: Maven org.openidentityplatform.openam:openam-core >=0 <=16.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c556-q2mh-477v lists affected ranges: Maven org.openidentityplatform.openam:openam-core >=0 <16.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-44202: 0.41% estimated exploitation activity in the next 30 days; percentile 35.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OpenAM (Open Identity Platform) is an open-source Identity and Access Management (IAM) platform derived from ForgeRock OpenAM, providing SSO, OAuth2, SAML, and OpenID Connect capabilities. It is widely deployed in enterprise environments as a central authentication gateway. The `/sessionservice` endpoint, used for internal session management operations, does not sufficiently restrict the URLs that authenticated users may register for session event notifications. Under certain conditions, this may result in outbound server-side requests to attacker-controlled destinations, potentially exposing session-related data. This behavior results in a server-side request forgery (SSRF) vulnerability, where an authenticated attacker can trigger outbound requests to arbitrary destinations.
Credit Discovered by JD-Security SHENYI Team
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-c556-q2mh-477v
- Revision 2 · amended ·
Amended from ghsa record GHSA-c556-q2mh-477v
- Revision 1 · created ·
Published from ghsa record GHSA-c556-q2mh-477v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44202 Advisory: OpenAM Authenticated Server-Side Request Forgery (SSRF) via `/sessionservice` IDs: CVE-2026-44202, GHSA-c556-q2mh-477v Record: https://patchnext.com/advisories/cve-2026-44202 (revision 3, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.openam:openam-core 16.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openidentityplatform.openam:openam-core: affected < 16.1.1; fixed in 16.1.1 ## Suggested inspection (read-only) - Maven org.openidentityplatform.openam:openam-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openidentityplatform.openam:openam-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c556-q2mh-477v (GitHub-reviewed advisory GHSA-c556-q2mh-477v lists affected ranges: Maven org.openidentityplatform.openam:openam-core >=0 <=16.0.6) - Verified: https://osv.dev/vulnerability/GHSA-c556-q2mh-477v (OSV record GHSA-c556-q2mh-477v lists affected ranges: Maven org.openidentityplatform.openam:openam-core >=0 <16.1.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…