Skip to content

← Public intelligence

Maven package

org.openhab.ui.bundles:org.openhab.ui.cometvisu

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9MavenPublished

    CometVisu Backend for openHAB has a path traversal vulnerability

    CVE-2024-42468 · GHSA-pcwp-26pw-j98w

    Affected
    • Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu <= 4.2.0
    Fixed in
    4.2.1· Vendor fix available
    Issue
    openHAB's CometVisuServlet is susceptible to an unauthenticated path traversal vulnerability. Local files on the server can be requested via HTTP GET on the CometVisuServlet. This vulnerability was discovered with the help of CodeQL's Uncontrolled data used in path expression query. Impact This issue may lead to Information Disclosure.

    Recommended action: Upgrade to 4.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.3MavenPublished

    CometVisu Backend for openHAB affected by RCE through path traversal

    CVE-2024-42469 · GHSA-f729-58x4-gqgf

    Affected
    • Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu <= 4.2.0
    Fixed in
    4.2.1· Vendor fix available
    Issue
    CometVisu's file system endpoints don't require authentication and additionally the endpoint to update an existing file is susceptible to path traversal. This makes it possible for an attacker to overwrite existing files on the openHAB instance. If the overwritten file is a shell script that is executed at a later time this vulnerability can allow remote code execution by an attacker. This vulnerability was discovered with the help of CodeQL's Uncontrolled data used in path expression query. Impact This issue may lead up to Remote Code Execution (RCE).

    Recommended action: Upgrade to 4.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.9MavenPublished

    CometVisu Backend for openHAB has a sensitive information disclosure vulnerability

    CVE-2024-42470 · GHSA-3g4c-hjhr-73rj

    Affected
    • Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu <= 4.2.0
    Fixed in
    4.2.1· Vendor fix available
    Issue
    Several endpoints in the CometVisu add-on of openHAB don't require authentication. This makes it possible for unauthenticated attackers to modify or to steal sensitive data. Impact This issue may lead to sensitive Information Disclosure.

    Recommended action: Upgrade to 4.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.8MavenPublished

    CometVisu Backend for openHAB affected by SSRF/XSS

    CVE-2024-42467 · GHSA-v7gr-mqpj-wwh3

    Affected
    • Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu >= 3.4.0.M4, <= 4.2.0
    Fixed in
    4.2.1· Vendor fix available
    Issue
    The proxy endpoint of openHAB's CometVisu add-on can be accessed without authentication. This proxy-feature can be exploited as Server-Side Request Forgery (SSRF) to induce GET HTTP requests to internal-only servers, in case openHAB is exposed in a non-private network. Furthermore, this proxy-feature can also be exploited as a Cross-Site Scripting (XSS) vulnerability, as an attacker is able to re-route a request to their server and return a page with malicious JavaScript code. Since the browser receives this data directly from the openHAB CometVisu UI, this JavaScript code will be executed with the origin of the CometVisu UI. This allows an attacker to exploit call endpoints on an openHAB server even if the openHAB server is located in a private network. (e.g. by sending an openHAB admin a link that proxies malicious JavaScript.) This vulnerability was discovered with the help of CodeQL's Server-side request forgery query. Impact This issue may lead up to Remote Code Execution (RCE)…

    Recommended action: Upgrade to 4.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →