CometVisu Backend for openHAB affected by RCE through path traversal
CVE-2024-42469GHSA-f729-58x4-gqgf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openhab.ui.bundles:org.openhab.ui.cometvisu 4.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu
- Affected
- <= 4.2.0
- Fixed in
- 4.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f729-58x4-gqgf lists affected ranges: Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu >=0 <=4.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-42469: 1.21% estimated exploitation activity in the next 30 days; percentile 68.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CometVisu's file system endpoints don't require authentication and additionally the endpoint to update an existing file is susceptible to path traversal. This makes it possible for an attacker to overwrite existing files on the openHAB instance. If the overwritten file is a shell script that is executed at a later time this vulnerability can allow remote code execution by an attacker. This vulnerability was discovered with the help of CodeQL's Uncontrolled data used in path expression query. Impact This issue may lead up to Remote Code Execution (RCE).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f729-58x4-gqgf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-42469 Advisory: CometVisu Backend for openHAB affected by RCE through path traversal IDs: CVE-2024-42469, GHSA-f729-58x4-gqgf Record: https://patchnext.com/advisories/cve-2024-42469 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openhab.ui.bundles:org.openhab.ui.cometvisu 4.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu: affected <= 4.2.0; fixed in 4.2.1 ## Suggested inspection (read-only) - Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openhab.ui.bundles:org.openhab.ui.cometvisu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f729-58x4-gqgf (GitHub-reviewed advisory GHSA-f729-58x4-gqgf lists affected ranges: Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu >=0 <=4.2.0) Commands are suggestions: review each one before running it.
Loading voting…