CometVisu Backend for openHAB affected by SSRF/XSS
CVE-2024-42467GHSA-v7gr-mqpj-wwh3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openhab.ui.bundles:org.openhab.ui.cometvisu 4.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu
- Affected
- >= 3.4.0.M4, <= 4.2.0
- Fixed in
- 4.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v7gr-mqpj-wwh3 lists affected ranges: Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu >=3.4.0.M4 <=4.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2024-42467: 1.04% estimated exploitation activity in the next 30 days; percentile 64.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The proxy endpoint of openHAB's CometVisu add-on can be accessed without authentication. This proxy-feature can be exploited as Server-Side Request Forgery (SSRF) to induce GET HTTP requests to internal-only servers, in case openHAB is exposed in a non-private network. Furthermore, this proxy-feature can also be exploited as a Cross-Site Scripting (XSS) vulnerability, as an attacker is able to re-route a request to their server and return a page with malicious JavaScript code. Since the browser receives this data directly from the openHAB CometVisu UI, this JavaScript code will be executed with the origin of the CometVisu UI. This allows an attacker to exploit call endpoints on an openHAB server even if the openHAB server is located in a private network. (e.g. by sending an openHAB admin a link that proxies malicious JavaScript.) This vulnerability was discovered with the help of CodeQL's Server-side request forgery query. Impact This issue may lead up to Remote Code Execution (RCE)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v7gr-mqpj-wwh3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-42467 Advisory: CometVisu Backend for openHAB affected by SSRF/XSS IDs: CVE-2024-42467, GHSA-v7gr-mqpj-wwh3 Record: https://patchnext.com/advisories/cve-2024-42467 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openhab.ui.bundles:org.openhab.ui.cometvisu 4.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu: affected >= 3.4.0.M4, <= 4.2.0; fixed in 4.2.1 ## Suggested inspection (read-only) - Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openhab.ui.bundles:org.openhab.ui.cometvisu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v7gr-mqpj-wwh3 (GitHub-reviewed advisory GHSA-v7gr-mqpj-wwh3 lists affected ranges: Maven org.openhab.ui.bundles:org.openhab.ui.cometvisu >=3.4.0.M4 <=4.2.0) Commands are suggestions: review each one before running it.
Loading voting…