Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:credentials

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3MavenPublished

    Jenkins Credentials plugin reveals encrypted values of credentials to users with Extended Read permission

    CVE-2024-47805 · GHSA-62jv-j4w7-5hh8

    Affected
    • Maven org.jenkins-ci.plugins:credentials < 1371.1373.v4eb; >= 1372, < 1381.v2c3a
    Fixed in
    1381.v2c3a1371.1373.v4eb· Vendor fix available
    Issue
    Jenkins Credentials Plugin 1380.va435002fa924 and earlier, except 1371.1373.v4ebfab7161e9, does not redact encrypted values of credentials using the SecretBytes type (e.g., Certificate credentials, or Secret file credentials from Plain Credentials Plugin) when accessing item config.xml via REST API or CLI. This allows attackers with Item/Extended Read permission to view encrypted SecretBytes values in credentials. This issue is similar to SECURITY-266 in the 2016-05-11 security advisory, which applied to the Secret type used for inline secrets and some credentials types. Credentials Plugin 1381.v2c3a12074dab redacts the encrypted values of credentials using the SecretBytes type in item config.xml files. This fix is only effective on Jenkins 2.479 and newer, LTS 2.462.3 and newer. While Credentials Plugin 1381.v2c3a12074dab can be installed on Jenkins 2.463 through 2.478 (both inclusive), encrypted values of credentials using the SecretBytes type will not be redacted when accessing…

    Recommended action: Upgrade to 1381.v2c3a (pre-release) or 1371.1373.v4eb by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Insertion of Sensitive Information into Externally-Accessible File or Directory in Jenkins Credentials Plugin

    CVE-2019-10320 · GHSA-xm94-9jw8-p6hw

    Affected
    • Maven org.jenkins-ci.plugins:credentials <= 2.1.18
    Fixed in
    2.1.19· Vendor fix available
    Issue
    Jenkins Credentials Plugin 2.1.18 and earlier allowed users with permission to create or update credentials to confirm the existence of files on the Jenkins master with an attacker-specified path, and obtain the certificate content of files containing a PKCS#12 certificate.

    Recommended action: Upgrade to 2.1.19 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.5MavenPublished

    Exposure of Sensitive Information to an Unauthorized Actor in Jenkins SSH Credentials Plugin

    CVE-2018-1000601 · GHSA-cwcf-5m5w-mq2w

    Affected
    • Maven org.jenkins-ci.plugins:credentials < 2.1.17
    Fixed in
    2.1.17· Vendor fix available
    Issue
    A arbitrary file read vulnerability exists in Jenkins SSH Credentials Plugin 1.13 and earlier in BasicSSHUserPrivateKey.java that allows attackers with a Jenkins account and the permission to configure credential bindings to read arbitrary files from the Jenkins master file system.

    Recommended action: Upgrade to 2.1.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.4MavenPublished

    Cross-site Scripting in Jenkins Credentials Plugin

    CVE-2022-29036 · GHSA-rvg5-f5fj-mxvg

    Affected
    • Maven org.jenkins-ci.plugins:credentials <= 2.6.1; >= 2.6.2, <= 1074.v60e6c29b; >= 1087.v16065d268466, <= 1087.v16065d268466; >= 1105, <= 1111.v35a
    Fixed in
    2.6.1.11087.1089.v2f1b_9a_b_040e41074.1076.v39c30cecb_0e2· Partial vendor fix
    Issue
    Jenkins Credentials Plugin 1111.v35a307992395 and earlier, except 1087.1089.v2f1b9ab040e4, 1074.1076.v39c30cecb0e2, and 2.6.1.1, does not escape the name and description of Credentials parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

    Recommended action: Upgrade to 1087.1089.v2f1b_9a_b_040e4, 1074.1076.v39c30cecb_0e2 or 2.6.1.1 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.1MavenPublished

    Cross-Site Request Forgery in Jenkins Credentials Plugin

    CVE-2021-21648 · GHSA-gchq-9r68-6jwv

    Affected
    • Maven org.jenkins-ci.plugins:credentials >= 2.3.16, < 2.3.19; >= 2.3.15, <= 2.3.15; >= 2.3.14, <= 2.3.14; >= 2.3.8, < 2.3.13.1; >= 2.3.1, < 2.3.7.1; < 2.3.0.1
    Fixed in
    2.3.192.3.7.12.3.15.12.3.14.12.3.13.12.3.0.1· Vendor fix available
    Issue
    Jenkins Credentials Plugin prior to 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, and 2.3.0.1 does not escape user-controlled information on a view it provides, resulting in a reflected cross-site scripting (XSS) vulnerability. Jenkins Credentials Plugin 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, and 2.3.0.1 restricts the user-controlled information it provides to a safe subset.

    Recommended action: Upgrade to 2.3.19, 2.3.15.1, 2.3.14.1 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →