Skip to content

← Actionable
Medium, CVSS 6.1

Cross-Site Request Forgery in Jenkins Credentials Plugin

CVE-2021-21648GHSA-gchq-9r68-6jwv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:credentials 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, 2.3.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.jenkins-ci.plugins:credentials

    Affected
    >= 2.3.16, < 2.3.19>= 2.3.15, <= 2.3.15>= 2.3.14, <= 2.3.14>= 2.3.8, < 2.3.13.1>= 2.3.1, < 2.3.7.1< 2.3.0.1
    Fixed in
    2.3.19, 2.3.7.1, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.0.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-gchq-9r68-6jwv lists affected ranges: Maven org.jenkins-ci.plugins:credentials >=2.3.16 =2.3.15 =2.3.14 =2.3.8 =2.3.1 =0 <2.3.0.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-21648: 11.31% estimated exploitation activity in the next 30 days; percentile 95.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Credentials Plugin prior to 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, and 2.3.0.1 does not escape user-controlled information on a view it provides, resulting in a reflected cross-site scripting (XSS) vulnerability. Jenkins Credentials Plugin 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, and 2.3.0.1 restricts the user-controlled information it provides to a safe subset.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gchq-9r68-6jwv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21648

Advisory: Cross-Site Request Forgery in Jenkins Credentials Plugin
IDs: CVE-2021-21648, GHSA-gchq-9r68-6jwv
Record: https://patchnext.com/advisories/cve-2021-21648 (revision 1, source checked 26 Oct 2026, 16:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:credentials 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, 2.3.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.plugins:credentials: affected >= 2.3.16, < 2.3.19; >= 2.3.15, <= 2.3.15; >= 2.3.14, <= 2.3.14; >= 2.3.8, < 2.3.13.1; >= 2.3.1, < 2.3.7.1; < 2.3.0.1; fixed in 2.3.19, 2.3.7.1, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.0.1

## Suggested inspection (read-only)
- Maven org.jenkins-ci.plugins:credentials: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.plugins:credentials.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gchq-9r68-6jwv (GitHub-reviewed advisory GHSA-gchq-9r68-6jwv lists affected ranges: Maven org.jenkins-ci.plugins:credentials >=2.3.16 =2.3.15 =2.3.14 =2.3.8 =2.3.1 =0 <2.3.0.1)

Commands are suggestions: review each one before running it.

Loading voting…