Skip to content

← Actionable
Medium, CVSS 5.3

Jenkins Credentials plugin reveals encrypted values of credentials to users with Extended Read permission

CVE-2024-47805GHSA-62jv-j4w7-5hh8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:credentials 1381.v2c3a, 1371.1373.v4eb), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47805: 0.59% estimated exploitation activity in the next 30 days; percentile 48.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Credentials Plugin 1380.va435002fa924 and earlier, except 1371.1373.v4ebfab7161e9, does not redact encrypted values of credentials using the SecretBytes type (e.g., Certificate credentials, or Secret file credentials from Plain Credentials Plugin) when accessing item config.xml via REST API or CLI. This allows attackers with Item/Extended Read permission to view encrypted SecretBytes values in credentials. This issue is similar to SECURITY-266 in the 2016-05-11 security advisory, which applied to the Secret type used for inline secrets and some credentials types. Credentials Plugin 1381.v2c3a12074dab redacts the encrypted values of credentials using the SecretBytes type in item config.xml files. This fix is only effective on Jenkins 2.479 and newer, LTS 2.462.3 and newer. While Credentials Plugin 1381.v2c3a12074dab can be installed on Jenkins 2.463 through 2.478 (both inclusive), encrypted values of credentials using the SecretBytes type will not be redacted when accessing…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-62jv-j4w7-5hh8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47805

Advisory: Jenkins Credentials plugin reveals encrypted values of credentials to users with Extended Read permission
IDs: CVE-2024-47805, GHSA-62jv-j4w7-5hh8
Record: https://patchnext.com/advisories/cve-2024-47805 (revision 1, source checked 26 Oct 2026, 16:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:credentials 1381.v2c3a, 1371.1373.v4eb. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.plugins:credentials: affected < 1371.1373.v4eb; >= 1372, < 1381.v2c3a; fixed in 1381.v2c3a, 1371.1373.v4eb

## Suggested inspection (read-only)
- Maven org.jenkins-ci.plugins:credentials: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.plugins:credentials.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-62jv-j4w7-5hh8 (GitHub-reviewed advisory GHSA-62jv-j4w7-5hh8 lists affected ranges: Maven org.jenkins-ci.plugins:credentials >=0 =1372 <1381.v2c3a)

Commands are suggestions: review each one before running it.

Loading voting…