Skip to content

← Public intelligence

Maven package

org.apache.tomcat.embed:tomcat-embed-jasper

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Apache Tomcat - XSS in generated JSPs

    CVE-2024-52318 · GHSA-f632-9449-3j4w

    Affected
    • Maven org.apache.tomcat.embed:tomcat-embed-jasper >= 9.0.96, <= 9.0.96; >= 11.0.0, <= 11.0.0; >= 10.1.31, <= 10.1.31
    Fixed in
    11.0.19.0.9710.1.32· Vendor fix available
    Issue
    The fix for improvement 69333 caused pooled JSP tags not to be released after use which in turn could cause output of some tags not to escaped as expected. This unescaped output could lead to XSS. Versions Affected: - Apache Tomcat 11.0.0 - Apache Tomcat 10.1.31 - Apache Tomcat 9.0.96 Mitigation: Users of the affected versions should apply one of the following mitigations: - Upgrade to Apache Tomcat 11.0.1 or later - Upgrade to Apache Tomcat 10.1.33 or later Note: 10.1.32 was not released - Upgrade to Apache Tomcat 9.0.97 or later

    Recommended action: Upgrade to 11.0.1, 10.1.32 or 9.0.97 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.1MavenPublished

    Authentication Bypass Using an Alternate Path or Channel in Apache Tomcat

    CVE-2016-5018 · GHSA-4v3g-g84w-hv7r

    Affected
    • Maven org.apache.tomcat.embed:tomcat-embed-jasper >= 9.0.0.M1, <= 9.0.0.M9; >= 8.5.0, <= 8.5.4; >= 8.0.0RC1, <= 8.0.36; >= 7.0.0, <= 7.0.70; >= 6.0.0, <= 6.0.45
    Fixed in
    7.0.728.5.58.0.379.0.0.M106.0.47· Vendor fix available
    Issue
    In Apache Tomcat 9.0.0.M1 to 9.0.0.M9, 8.5.0 to 8.5.4, 8.0.0.RC1 to 8.0.36, 7.0.0 to 7.0.70 and 6.0.0 to 6.0.45 a malicious web application was able to bypass a configured SecurityManager via a Tomcat utility method that was accessible to web applications.

    Recommended action: Upgrade to 9.0.0.M10, 8.5.5, 8.0.37 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →