Apache Tomcat - XSS in generated JSPs
CVE-2024-52318GHSA-f632-9449-3j4w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-jasper 11.0.1, 10.1.32, 9.0.97; org.apache.tomcat.embed:tomcat-embed-jasper 11.0.1, 10.1.32, 9.0.97; org.apache.tomcat:tomcat 11.0.1, 10.1.32, 9.0.97), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-jasper
- Affected
- >= 11.0.0, <= 11.0.0>= 10.1.31, <= 10.1.31>= 9.0.96, <= 9.0.96
- Fixed in
- 11.0.1, 9.0.97, 10.1.32
Maven org.apache.tomcat.embed:tomcat-embed-jasper
- Affected
- >= 9.0.96, <= 9.0.96>= 11.0.0, <= 11.0.0>= 10.1.31, <= 10.1.31
- Fixed in
- 11.0.1, 9.0.97, 10.1.32
Maven org.apache.tomcat:tomcat
- Affected
- >= 11.0.0, <= 11.0.0>= 10.1.31, <= 10.1.31>= 9.0.96, <= 9.0.96
- Fixed in
- 11.0.1, 9.0.97, 10.1.32
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f632-9449-3j4w lists affected ranges: Maven org.apache.tomcat:tomcat-jasper >=11.0.0 =10.1.31 =9.0.96 =9.0.96 =11.0.0 =10.1.31 =11.0.0 =10.1.31 =9.0.96 <=9.0.96
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-52318: 1.88% estimated exploitation activity in the next 30 days; percentile 79.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description: The fix for improvement 69333 caused pooled JSP tags not to be released after use which in turn could cause output of some tags not to escaped as expected. This unescaped output could lead to XSS. Versions Affected: - Apache Tomcat 11.0.0 - Apache Tomcat 10.1.31 - Apache Tomcat 9.0.96 Mitigation: Users of the affected versions should apply one of the following mitigations: - Upgrade to Apache Tomcat 11.0.1 or later - Upgrade to Apache Tomcat 10.1.33 or later Note: 10.1.32 was not released - Upgrade to Apache Tomcat 9.0.97 or later
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f632-9449-3j4w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52318 Advisory: Apache Tomcat - XSS in generated JSPs IDs: CVE-2024-52318, GHSA-f632-9449-3j4w Record: https://patchnext.com/advisories/cve-2024-52318 (revision 1, source checked 26 Oct 2026, 16:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-jasper 11.0.1, 10.1.32, 9.0.97; org.apache.tomcat.embed:tomcat-embed-jasper 11.0.1, 10.1.32, 9.0.97; org.apache.tomcat:tomcat 11.0.1, 10.1.32, 9.0.97. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-jasper: affected >= 11.0.0, <= 11.0.0; >= 10.1.31, <= 10.1.31; >= 9.0.96, <= 9.0.96; fixed in 11.0.1, 9.0.97, 10.1.32 - Maven org.apache.tomcat.embed:tomcat-embed-jasper: affected >= 9.0.96, <= 9.0.96; >= 11.0.0, <= 11.0.0; >= 10.1.31, <= 10.1.31; fixed in 11.0.1, 9.0.97, 10.1.32 - Maven org.apache.tomcat:tomcat: affected >= 11.0.0, <= 11.0.0; >= 10.1.31, <= 10.1.31; >= 9.0.96, <= 9.0.96; fixed in 11.0.1, 9.0.97, 10.1.32 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-jasper: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-jasper: check the installed version with your package manager. - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-jasper, org.apache.tomcat.embed:tomcat-embed-jasper, org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f632-9449-3j4w (GitHub-reviewed advisory GHSA-f632-9449-3j4w lists affected ranges: Maven org.apache.tomcat:tomcat-jasper >=11.0.0 =10.1.31 =9.0.96 =9.0.96 =11.0.0 =10.1.31 =11.0.0 =10.1.31 =9.0.96 <=9.0.96) Commands are suggestions: review each one before running it.
Loading voting…