Skip to content

← Actionable
Critical, CVSS 9.1

Authentication Bypass Using an Alternate Path or Channel in Apache Tomcat

CVE-2016-5018GHSA-4v3g-g84w-hv7r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-jasper 9.0.0.M10, 8.5.5, 8.0.37, 7.0.72; org.apache.tomcat.embed:tomcat-embed-jasper 9.0.0.M10, 8.5.5, 8.0.37, 7.0.72, 6.0.47; org.apache.tomcat:jasper 6.0.47), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4v3g-g84w-hv7r lists affected ranges: Maven org.apache.tomcat:tomcat-jasper >=9.0.0.M1 =8.5.0 =8.0.0RC1 =7.0.0 =6.0.0 =9.0.0.M1 =8.5.0 =8.0.0RC1 =7.0.0 =6.0.0 <=6.0.45

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2016-5018: 10.30% estimated exploitation activity in the next 30 days; percentile 95.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Apache Tomcat 9.0.0.M1 to 9.0.0.M9, 8.5.0 to 8.5.4, 8.0.0.RC1 to 8.0.36, 7.0.0 to 7.0.70 and 6.0.0 to 6.0.45 a malicious web application was able to bypass a configured SecurityManager via a Tomcat utility method that was accessible to web applications.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4v3g-g84w-hv7r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-5018

Advisory: Authentication Bypass Using an Alternate Path or Channel in Apache Tomcat
IDs: CVE-2016-5018, GHSA-4v3g-g84w-hv7r
Record: https://patchnext.com/advisories/cve-2016-5018 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-jasper 9.0.0.M10, 8.5.5, 8.0.37, 7.0.72; org.apache.tomcat.embed:tomcat-embed-jasper 9.0.0.M10, 8.5.5, 8.0.37, 7.0.72, 6.0.47; org.apache.tomcat:jasper 6.0.47. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-jasper: affected >= 9.0.0.M1, <= 9.0.0.M9; >= 8.5.0, <= 8.5.4; >= 8.0.0RC1, <= 8.0.36; >= 7.0.0, <= 7.0.70; fixed in 7.0.72, 8.5.5, 8.0.37, 9.0.0.M10
- Maven org.apache.tomcat.embed:tomcat-embed-jasper: affected >= 9.0.0.M1, <= 9.0.0.M9; >= 8.5.0, <= 8.5.4; >= 8.0.0RC1, <= 8.0.36; >= 7.0.0, <= 7.0.70; >= 6.0.0, <= 6.0.45; fixed in 7.0.72, 8.5.5, 8.0.37, 9.0.0.M10, 6.0.47
- Maven org.apache.tomcat:jasper: affected >= 6.0.0, <= 6.0.45; fixed in 6.0.47

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-jasper: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-jasper: check the installed version with your package manager.
- Maven org.apache.tomcat:jasper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-jasper, org.apache.tomcat.embed:tomcat-embed-jasper, org.apache.tomcat:jasper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4v3g-g84w-hv7r (GitHub-reviewed advisory GHSA-4v3g-g84w-hv7r lists affected ranges: Maven org.apache.tomcat:tomcat-jasper >=9.0.0.M1 =8.5.0 =8.0.0RC1 =7.0.0 =6.0.0 =9.0.0.M1 =8.5.0 =8.0.0RC1 =7.0.0 =6.0.0 <=6.0.45)

Commands are suggestions: review each one before running it.

Loading voting…