Skip to content

← Public intelligence

Maven package

org.apache.syncope.core:syncope-core-spring

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.2MavenPublished

    Apache Syncope has an Improper Isolation or Compartmentalization vulnerability

    CVE-2026-42782 · GHSA-gq7g-vg2q-jvq3

    Affected
    • Maven org.apache.syncope.core:syncope-core-spring >= 3.0.0-M0, <= 3.0.16; >= 4.0.0-M0, < 4.0.6; >= 4.1.0-M0, < 4.1.1
    Fixed in
    4.0.64.1.1· Partial vendor fix
    Issue
    Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.

    Recommended action: Upgrade to 4.1.1 or 4.0.6 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.2MavenPublished

    Apache Syncope allows malicious administrators to inject Groovy code

    CVE-2025-57738 · GHSA-825g-mm5v-ggq4

    Affected
    • Maven org.apache.syncope.core:syncope-core-spring < 3.0.14; >= 4.0.0-M0, < 4.0.2
    Fixed in
    4.0.23.0.14· Vendor fix available
    Issue
    Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload. Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance. Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.

    Recommended action: Upgrade to 4.0.2 or 3.0.14 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →