Apache Syncope has an Improper Isolation or Compartmentalization vulnerability
CVE-2026-42782GHSA-gq7g-vg2q-jvq3
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.syncope.core:syncope-core-spring
- Affected
- >= 3.0.0-M0, <= 3.0.16>= 4.0.0-M0, < 4.0.6>= 4.1.0-M0, < 4.1.1
- Fixed in
- 4.0.6, 4.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gq7g-vg2q-jvq3 lists affected ranges: Maven org.apache.syncope.core:syncope-core-spring >=3.0.0-M0 =4.0.0-M0 =4.1.0-M0 <4.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-42782: 0.65% estimated exploitation activity in the next 30 days; percentile 51.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gq7g-vg2q-jvq3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42782 Advisory: Apache Syncope has an Improper Isolation or Compartmentalization vulnerability IDs: CVE-2026-42782, GHSA-gq7g-vg2q-jvq3 Record: https://patchnext.com/advisories/cve-2026-42782 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.syncope.core:syncope-core-spring 4.1.1, 4.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.syncope.core:syncope-core-spring: affected >= 3.0.0-M0, <= 3.0.16; >= 4.0.0-M0, < 4.0.6; >= 4.1.0-M0, < 4.1.1; fixed in 4.0.6, 4.1.1 ## Suggested inspection (read-only) - Maven org.apache.syncope.core:syncope-core-spring: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.syncope.core:syncope-core-spring. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gq7g-vg2q-jvq3 (GitHub-reviewed advisory GHSA-gq7g-vg2q-jvq3 lists affected ranges: Maven org.apache.syncope.core:syncope-core-spring >=3.0.0-M0 =4.0.0-M0 =4.1.0-M0 <4.1.1) Commands are suggestions: review each one before running it.
Loading voting…