Apache Syncope allows malicious administrators to inject Groovy code
CVE-2025-57738GHSA-825g-mm5v-ggq4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.syncope.core:syncope-core-spring 4.0.2, 3.0.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.syncope.core:syncope-core-spring
- Affected
- < 3.0.14>= 4.0.0-M0, < 4.0.2
- Fixed in
- 4.0.2, 3.0.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-825g-mm5v-ggq4 lists affected ranges: Maven org.apache.syncope.core:syncope-core-spring >=0 =4.0.0-M0 <4.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-57738: 23.18% estimated exploitation activity in the next 30 days; percentile 97.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload. Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance. Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-825g-mm5v-ggq4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57738 Advisory: Apache Syncope allows malicious administrators to inject Groovy code IDs: CVE-2025-57738, GHSA-825g-mm5v-ggq4 Record: https://patchnext.com/advisories/cve-2025-57738 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.syncope.core:syncope-core-spring 4.0.2, 3.0.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.syncope.core:syncope-core-spring: affected < 3.0.14; >= 4.0.0-M0, < 4.0.2; fixed in 4.0.2, 3.0.14 ## Suggested inspection (read-only) - Maven org.apache.syncope.core:syncope-core-spring: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.syncope.core:syncope-core-spring. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-825g-mm5v-ggq4 (GitHub-reviewed advisory GHSA-825g-mm5v-ggq4 lists affected ranges: Maven org.apache.syncope.core:syncope-core-spring >=0 =4.0.0-M0 <4.0.2) Commands are suggestions: review each one before running it.
Loading voting…