Skip to content

← Public intelligence

Maven package

org.apache.struts:struts2-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

58 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8Exploited · CISA KEVMavenPublished

    Remote code execution in Apache Struts

    CVE-2020-17530 · GHSA-jc35-q369-45pv

    Affected
    • Maven org.apache.struts:struts2-core >= 2.0.0, < 2.5.26
    Fixed in
    2.5.26· Vendor fix available
    Issue
    Forced OGNL evaluation, when evaluated on raw user input in tag attributes, may lead to remote code execution.

    Recommended action: Upgrade to 2.5.26 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)cisa.gov (2)Source checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Improperly Controlled Modification of Dynamically-Determined Object Attributes in Apache Struts

    CVE-2019-0230 · GHSA-wp4h-pvgw-5727

    Affected
    • Maven org.apache.struts:struts2-core >= 2.0.0, < 2.5.22
    Fixed in
    2.5.22· Vendor fix available
    Issue
    Apache Struts 2.0.0 to 2.5.20 forced double OGNL evaluation, when evaluated on raw user input in tag attributes, may lead to remote code execution.

    Recommended action: Upgrade to 2.5.22 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.1Exploited · CISA KEVMavenPublished

    Apache Struts vulnerable to remote command execution (RCE) due to improper input validation

    CVE-2018-11776 · GHSA-cr6j-3jp9-rw65

    Affected
    • Maven org.apache.struts:struts2-core >= 2.0.4, <= 2.3.34; >= 2.5, <= 2.5.16
    Fixed in
    2.5.172.3.35· Vendor fix available
    Issue
    Apache Struts contains a Remote Code Execution when using results with no namespace and it's upper actions have no or wildcard namespace. The same flaw exists when using a url tag with no value, action set, and it's upper actions have no or wildcard namespace.

    Recommended action: Upgrade to 2.5.17 or 2.3.35 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:cisa.gov (1)github.com (2)Source checked Evidence →
  4. Critical, CVSS 10.0Exploited · CISA KEVMavenPublished

    Apache Struts vulnerable to remote arbitrary command execution due to improper input validation

    CVE-2017-5638 · GHSA-j77q-2qqg-6989

    Affected
    • Maven org.apache.struts:struts2-core >= 2.3.0, <= 2.3.31; >= 2.5.0, <= 2.5.10
    Fixed in
    2.3.322.5.10.1· Vendor fix available
    Issue
    Apache Struts versions prior to 2.3.32 and 2.5.10.1 contain incorrect exception handling and error-message generation during file-upload attempts using the Jakarta Multipart parser, which allows remote attackers to execute arbitrary commands via a crafted Content-Type, Content-Disposition, or Content-Length HTTP header, as exploited in the wild in March 2017 with a Content-Type header containing a #cmd= string.

    Recommended action: Upgrade to 2.5.10.1 or 2.3.32 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:cisa.gov (1)github.com (2)Source checked Evidence →
  5. High, CVSS 7.5MavenPublished

    Apache Struts allows entering a custom URL in a form field if built-in URLValidator is used

    CVE-2017-9804 · GHSA-x5x7-3v85-wpc4

    Affected
    • Maven org.apache.struts:struts2-core >= 2.3.7, <= 2.3.33; >= 2.5.0, <= 2.5.12
    Fixed in
    2.3.342.5.13· Vendor fix available
    Issue
    In Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12, if an application allows entering a URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. NOTE: this vulnerability exists because of an incomplete fix for S2-047 / CVE-2017-7672.

    Recommended action: Upgrade to 2.5.13 or 2.3.34 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 7.5MavenPublished

    Spring AOP functionality (Struts) vulnerable to DoS attack

    CVE-2017-9787 · GHSA-8mr5-h28g-36qx

    Affected
    • Maven org.apache.struts:struts2-core >= 2.5.0, < 2.5.12; >= 2.3.7, < 2.3.33
    Fixed in
    2.3.332.5.12· Vendor fix available
    Issue
    When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

    Recommended action: Upgrade to 2.5.12 or 2.3.33 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 5.9MavenPublished

    Apache Struts Improper Input Validation vulnerability

    CVE-2017-7672 · GHSA-9gp7-jvm2-r4mx

    Affected
    • Maven org.apache.struts:struts2-core >= 2.5.0, < 2.5.12
    Fixed in
    2.5.12· Vendor fix available
    Issue
    If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

    Recommended action: Upgrade to 2.5.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. Critical, CVSS 9.8MavenPublished

    Apache Struts 2.0.1 uses an unintentional expression in a Freemarker tag instead of string literal

    CVE-2017-12611 · GHSA-8fx9-5hx8-crhm

    Affected
    • Maven org.apache.struts:struts2-core >= 2.0.1, <= 2.3.33; >= 2.5.0, <= 2.5.10.1
    Fixed in
    2.3.342.5.11· Vendor fix available
    Issue
    In Apache Struts 2.0.1 through 2.3.33 and 2.5 through 2.5.10.1, using an unintentional expression in a Freemarker tag instead of string literals can lead to a RCE attack.

    Recommended action: Upgrade to 2.5.11 or 2.3.34 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →