Skip to content

← Actionable
Critical, CVSS 10.0Exploited · CISA KEV

Apache Struts vulnerable to remote arbitrary command execution due to improper input validation

CVE-2017-5638GHSA-j77q-2qqg-6989

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.struts:struts2-core 2.5.10.1, 2.3.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
10.0 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:H
EPSS
  • CVE-2017-5638: 100.00% estimated exploitation activity in the next 30 days; percentile 99.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Struts versions prior to 2.3.32 and 2.5.10.1 contain incorrect exception handling and error-message generation during file-upload attempts using the Jakarta Multipart parser, which allows remote attackers to execute arbitrary commands via a crafted Content-Type, Content-Disposition, or Content-Length HTTP header, as exploited in the wild in March 2017 with a Content-Type header containing a #cmd= string.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j77q-2qqg-6989

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-5638

Advisory: Apache Struts vulnerable to remote arbitrary command execution due to improper input validation
IDs: CVE-2017-5638, GHSA-j77q-2qqg-6989
Record: https://patchnext.com/advisories/cve-2017-5638 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.apache.struts:struts2-core 2.5.10.1, 2.3.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.struts:struts2-core: affected >= 2.3.0, <= 2.3.31; >= 2.5.0, <= 2.5.10; fixed in 2.3.32, 2.5.10.1

## Suggested inspection (read-only)
- Maven org.apache.struts:struts2-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.struts:struts2-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2017-5638 to the Known Exploited Vulnerabilities catalog on 2021-11-03.)
- Verified: https://github.com/advisories/GHSA-j77q-2qqg-6989 (GitHub-reviewed advisory GHSA-j77q-2qqg-6989 lists affected ranges: Maven org.apache.struts:struts2-core >=2.3.0 =2.5.0 <=2.5.10)

Commands are suggestions: review each one before running it.

Loading voting…